Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

2004 SV6 - 'Check Powertrain' caution

Discussion in 'VZ Holden Commodore (2004 - 2006)' started by gam, Jan 28, 2006.

  1. gam

    gam New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Jul 3, 2005
    Members Ride:
    SV6
    Howdy all. Was just driving my 2004 Holden SV6, and the 'Check Powertrain' caption came on :my: . Book says "it indicates an emission control fault. Although the vehicle may still be driveable, reduce speed blah blah blah, and get it checked by Holden".

    Can't get it looked at until Monday (Today is Saturday).

    Has anyone elso had this, does anyone know what it means, and if it is hard / time consuming on their part to fix????

    Any Clues - please pass em on. :confused:

    cheers
    Gam
     
  2. benzor

    benzor yawn :(

    Messages:
    301
    Likes Received:
    1
    Trophy Points:
    0
    Joined:
    Jan 5, 2006
    Members Ride:
    SV6!
    Happened when i pulled my MAF out :)

    Could be anything

    Engine
    o2's
    MAF
    Throttle Body.
     
  3. GroopA

    GroopA New Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    May 6, 2005
    Location:
    Perth, SOR
    Members Ride:
    '05 Impulse VZ SV6
    Had it happen to me too.
    Was just a faulty O2 sensor which got replaced under warranty.
    Didn't harm the car at all, just ran a little bit richer.
     
  4. nightmare

    nightmare New Member

    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Jan 30, 2006
    Members Ride:
    VZ SV6
  5. Doctor Bob

    Doctor Bob Grandpa

    Messages:
    2,786
    Likes Received:
    51
    Trophy Points:
    0
    Joined:
    May 23, 2004
    Location:
    Mornington Peninsula
    Members Ride:
    VT V6 Exec & VN V6 Exec
    The check powertrain warning is nothing to do with the software issue, it indicates a fault with the engine management system & should be checked by a dealer asap.

    Rob
     
  6. HOTSV.6

    HOTSV.6 Guest

    Happened to me a couple of months ago. Turned out to be a faulty left bank O2 sensor that was replaced under warranty.
     
  7. jaisvz

    jaisvz New Member

    Messages:
    230
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Dec 14, 2005
    Location:
    Geelong
    Members Ride:
    Black VZ SV6
    On my way home from work last night about 10 mins into my drive home... my car started beeping like crazy and "CHECK POWERTRAIN" caution came on... i see other people have had this and it turns out to be a faulty o2 sensor? I shall ring holden and get them to have i look. My sv6 has only done 22,000k's and i don't thrash it, mainly all highway driving... so i hardly think there would be something majorly wrong!
     
    Last edited: Jul 20, 2006
  8. Doctor Bob

    Doctor Bob Grandpa

    Messages:
    2,786
    Likes Received:
    51
    Trophy Points:
    0
    Joined:
    May 23, 2004
    Location:
    Mornington Peninsula
    Members Ride:
    VT V6 Exec & VN V6 Exec
    it means there is a fault with the cars engine management system & it needs to be checked.
    as described in the owners handbook...

    Rob
     
  9. jaisvz

    jaisvz New Member

    Messages:
    230
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Dec 14, 2005
    Location:
    Geelong
    Members Ride:
    Black VZ SV6
    Faulty 02 sensor....
     
  10. VZSV6

    VZSV6 Guest

    unplug the sensor disconnect the negative terminal for 10min replace the sensor back then reconnect the terminal..fixed
     
  11. Doctor Bob

    Doctor Bob Grandpa

    Messages:
    2,786
    Likes Received:
    51
    Trophy Points:
    0
    Joined:
    May 23, 2004
    Location:
    Mornington Peninsula
    Members Ride:
    VT V6 Exec & VN V6 Exec
    the car is under warranty dont go unplugging things if you dont understand, take it to get it fixed by someone who knows what they are doing.
     
  12. jaisvz

    jaisvz New Member

    Messages:
    230
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Dec 14, 2005
    Location:
    Geelong
    Members Ride:
    Black VZ SV6
    Um, its already replaced. ;)
     
  13. JanetSSV

    JanetSSV New Member

    Messages:
    151
    Likes Received:
    1
    Trophy Points:
    0
    Joined:
    Feb 6, 2006
    Location:
    Mandurah W.A.
    Members Ride:
    VE SSV Ignition
    Mine's just come up with the same warning. Rang Holden and advised not to drive if possible. Have another option so that's ok for now. Has anyone else had their car in for this warning and if so what was the problem causing it?
     
  14. JanetSSV

    JanetSSV New Member

    Messages:
    151
    Likes Received:
    1
    Trophy Points:
    0
    Joined:
    Feb 6, 2006
    Location:
    Mandurah W.A.
    Members Ride:
    VE SSV Ignition
    Had mine in today and was told it was only a software issue which has been updated. Will be interesting to see what happens.
     
  15. JanetSSV

    JanetSSV New Member

    Messages:
    151
    Likes Received:
    1
    Trophy Points:
    0
    Joined:
    Feb 6, 2006
    Location:
    Mandurah W.A.
    Members Ride:
    VE SSV Ignition
    Got the same warning come on again Wed. morning. Took her back in again in the arvo. Ran a scan told it may be software or a wiring problem. Still safe to drive. Can't get her back in until Monday (partly due to my schedule with tafe) Then they have to do more tests. Good now I've got no car for my 1 day off. yay fun
     
  16. JanetSSV

    JanetSSV New Member

    Messages:
    151
    Likes Received:
    1
    Trophy Points:
    0
    Joined:
    Feb 6, 2006
    Location:
    Mandurah W.A.
    Members Ride:
    VE SSV Ignition
    Took her up to Freo today (about 150 km round trip) she's running really rich. used nearly half a tank normal would be about 1/4 . per 100km started at 14 for around town by the time we got home was on 12.2. that's really bad. bet they dont give a rats ass about the fuel I've wasted when they told me she was ok to run and they knew where I had to go this weekend. Damn them. would have taken the VL out for the run but the fuel pumps are on the way in her atm. Had to get her towed home on Monday arvo. No win situation atm.
     
    Last edited: Sep 3, 2006
  17. JanetSSV

    JanetSSV New Member

    Messages:
    151
    Likes Received:
    1
    Trophy Points:
    0
    Joined:
    Feb 6, 2006
    Location:
    Mandurah W.A.
    Members Ride:
    VE SSV Ignition
    O2 sensor replaced. hope all else is gonna be good too now
     
  18. sv6_driva

    sv6_driva New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Dec 14, 2007
    Members Ride:
    04 VZ 3.6 SV6 Commodore
    Oxygen Sensor

    My Oxygen sensor (left side of block) **** itself at about 25k and gave this warning on dash. Replaced under warranty and fine now. Seems like a very common problem!
     
  19. Kersh

    Kersh New Member

    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Jun 27, 2005
    Location:
    Woonga, VIC
    Members Ride:
    VE SS Ute '08
    I had the same prob with my 06 VZ the other day, its only done 23000 km. Tech2 readout said 4 oxygen sensors were stuffed, they are all fine tho, just needs a software update.
     
  20. itsonlyme

    itsonlyme New Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Apr 10, 2006
    Members Ride:
    VZ SV6
    yeah happened to my parents got it replaced within a day under warranty then it came on again so took it back and it has come on again since
     

Share This Page