Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: RB30 Engine Troubleshooting/Maintenance Step by step

  1. #1
    VL Berlina 5speed's Avatar
    VL Berlina 5speed is offline Apprentice Panel Pusher
    Ride
    Project VL Show car, VS Exec, VY Ute, YZ250F

    Join Date
    Oct 2005
    Location
    Adelaide
    Posts
    2,684

    Default RB30 Engine Troubleshooting/Maintenance Step by step

    I recently found this on the Street Commodores Fourm and i thought that it was very helpful with common probs on vls, so i thought i will post it to help people have a quick refferance and to help newer members that have common problems.

    Credit goes to VL_RACER of Street Commodores for this write up.
    VL_RACER is now a registerd member of JustCommodores and is under the name of snake_VL, so if your are ever in needed of advice snake_VL's words are word's to be sought after.


    1. Air flow meter: check the connections including rubber boot, clean with contact cleaner if necessary. remove the airflow meter (undo the clamp behind it and remove the top of the airbox and air flow meter together) and clean using contact cleaner or some other cleaner thats safe on electrical components. clean out the airbox and replace the air filter if necessary ($10 for a cheap one, $100 for K&N) reinstall everything

    if the car is stalling after starting or seems to be choking still after this, check AAC valve, air regulator, make sure there's no air leaks, then replace the air flow meter ($20-$60 from wreckers, approx $150 reconditioned, about $400-$600 new)

    TO CHECK AND ADJUST MIXTURE:
    1. start and run the engine until its at operating temperature
    2. set idle speed and timing to specified values
    3. take off the passenger kick panel to view the LED's on the ECU
    4. start and run the motor at 2000rpm for 2 mins
    5. check the flashes from the LED's on the ecu while at 2000rpm, they should both flash together more than 5 times every 10 seconds. if they don't you have ecu or oxygen sensor issues (refer to the picture at the bottom explaining the interpretation of flashes other than what are stated)
    6. if there are more than 5 flashes per 10 secs, stop the engine, disconnect the wiring connector from the AAC valve and the throttle switch
    7. start and run the engine at 2000rpm for 2 mins
    8. let the engine idle
    9. the leds should now flash simultaneously
    10. if the green light is flashing more the mixture is lean, if the red is flashing more the mixture is richer than it should be.
    10. if the LED's do not flash together remove the plug next to the Air flow meter connector and adjust the screw until they flash together (clockwise raises the resistance and leans the mixture, anti clockwise lowers the resistance and richens the mixture)
    11. replace the plug, replace the AAC and throttle switch connectors and return to instruction 4. do the test again to check that the mixture is now right
    12. if the mixture cannot be adjusted so that the leds flash together, its time to test the AFM

    TO TEST AFM:
    pull back the rubber boot on the AFM connector revealing the wires. grab your multimeter and stick the probes on wire 4 (white) and 3 (1 being the closest to the airbox) with the multimeter on DC voltage. turn the ignition on and the voltage reading should be between 1.26V (lean) and 1.32V (rich). this is the base setting and if it is out then the AFM wont be able to be adjusted to a satisfactory mixture (meaning you need a new one)

    and just for interests sake you can test the mixture by putting the probes on wire 1 and 3 with the key on and measuring the voltage. 3.6V is the factory setting which is lean, with 2.0V being rich. the mixture should be in the vacinity of 2.0-4.0i couldn't get the LED's to flash and therefore couldn't set it using the computer so i did it this way and set it to 3.5V (AFM resistance of 375 ohms) and then checked it using the computer and it was right, LED's flashing together.


    2. Throttle body: undo the bolt attaching the intake piping to the throttle cable bracket. undo the pcv valve hose. undo the clamp holding the intake to the throttle body. undo the clamp holding the piping to the air flow meter. clean the throttle body with throttle body cleaner making sure you get all of the black crap out. reinstall intake and clamps and start.

    this will improve throttle response and a tendency to stutter a bit when the accelerator is pressed suddenly


    3. AAC Valve: undo the connector and 2 screws holding it to the plenum chamber. clean the black carbon off the valve with throttle body cleaner. check that the valve has plenty of movement and won't be prone to sticking, this will raise the idle by allowing too much air to bypass the throttle body or stop the flow all together depending where it is stuck. if it is a bit sticky put a little wd40 to make it slide easier. reinstall the valve.


    4. Air regulator: undo the connector and the hose clamps above and below the valve. remove and clean with throttle body cleaner. reinstall

    this will correct warm up running issues and influences the air flow meter so should be done before replacing the air flow meter


    5. Coolant Temperature sensor : check connector and clean if necessary. make sure the earth to the right of the connector is secure.

    this corrects a temp guage that isn't working and a engine that is running rich and using heaps of fuel. if its still running rich it may be the oxygen sensor (approx $200 i think)


    6: Distributor: remove the 2 screws and check the cap and rotor for wear, corrosion and tracking. a pitted rotor connection will need replacing ($10). replace the cap if necessary ($25) also check plugs (starting at $20 a set) and replace if neccessary


    7. Fuel filter: start the engine, remove the fuel pump fuse (#3 i think) and wait for the engine to stall. run the starter to release fuel pressure. put the fuse back in. working under the rear axle remove the clamps and hoses and replace the filter (make sure the flow arrow is the right way).

    this will improve power and smoothness.


    8. Crank Angle Sensor Boot: my boot had fallen to bits allowing water in and causing major corrosion of the terminals and wires and dodgey running one day when it got a bit wet. i've also found that it was the cause of a afm fault code being displayed one day when i ran a diagnostic (its on the same circuit as the afm). a boot and connector kit can be bought for about $15 from repco to fix this problem


    9. Timing: the timing on our vl was 22 degrees btdc when we bought it, meaning it would ping its tits off on regular unleaded but run great on premium. i got it brought back to 17 degrees (15 is standard) and continued to use premium but it then started to run like crap when it was cold (coughing and spluttering on take off until the temp went up). its now on 20 degrees (still with premium) and runs a lot better.

    standard vl's should run 15 degrees on regular unleaded or up to 20 on premium. going over 20 isn't advised because of pinging issues even on premium but then again i'm yet to talk to a mechanic who doesn't think i'm nuts for going up above standard at all.

    TO ADJUST: get yourself a timing light (or borrow one). make sure you get a xenon one cos neon ones aren't worth ****. xenon ones are about $60 from supercheap and about $100 from repco. hook it up (read the instructions that come with it), start the motor and undo the 12mm bolt next to the dizzy. counting the timing marks from left to right on the crankshaft pulley where the first is 0 and the last is 30, move the distributor until you get the setting you want. tighten the bolt and check that the setting is still right. its a good idea to make a mark on the dizzy bolt slider where 15 and 20 degrees are so then you can adjust it yourself between those without having to need a timing light again. check and adjust the mixture after this for optimum results


    10. Radiator/Cooling System: The radiator and cooling system should be flushed every 40,000k's or 2 years and thermostats changed every 2-3 years as well. before you start you should check everywhere for leaks so that you can go and get parts you need before dumping the coolant. common places to look are top and bottom hose housings, hoses, water pump, heater hoses, welch plugs etc. i got the following parts to ensure mine is in good working order:

    - top radiator hose
    - bottom radiator hose
    - top housing
    - thermostat housing
    - thermostat
    - radiator cap
    - silicone sealant
    - tectaloy ultra cool gold (make sure you get coolant suitable for alloy heads)
    - demineralised water
    - hose clamps
    - hose from filler neck to expansion tank

    i'm being very thorough here so all that is absolutely necessary is the coolant and water. now to drop the coolant:

    1. put the heater to the hot position
    2. remove the bottom radiator hose and radiator cap and drain the coolant into a drain tin
    3. remove the cylinder block drain plug (its the lower of the 2 plugs under the exhaust manifold towards the back of the engine). you may need to put some wd40 on this the day before to loosen it up cos they are sticky little buggers
    4. once drained remove all hoses from the radiator, remove the shroud screws and clips on the front plastic piece
    5. lift the shroud up slightly out of the bottom clips and push back over the fan
    6. get some pliers on the radiator clips and remove them, slide out the radiator
    7. block the inlet and reverse flush through the outlet until the water flowing from the filler neck is clean
    8. stand up the radiator and spray it rear to front to wash out any dirt, bugs etc in it
    9. reinstall the radiator
    10. if replacing the thermostat remove the lower hose and thermostat housing (it'll be stuck so lever it out)
    11. pull the thermostat out and clean all around the mounting faces
    12. put the new thermostat in with the jiggle valve to the top and the gasket and silicone sealer
    13. intall the cover and do the bolts up to 29NM (same tightness as plugs)
    14. while waiting for the sealer to set replace the top hose housing, it should come with a gasket
    15. once the sealer has hardened reinstall all hoses and clamps
    16. fill the radiator and replace the cap
    TO BLEED: (vl's need to be bled because the highest water jacket is above the highest part of the radiator)
    18. undo the bleed bolt near the coolant temp sensor
    17. remove the hose going from the filler neck to the expansion tank at the expansion tank end, hold it higher than the bolt hole and using a small funnel, fill until coolant runs out of the bleed bolt hole
    18. reinstall the bolt
    19. remove the bleed bolt on the plenum
    20. fill till coolant comes out as above
    21. reinstall the bleed bolt and hose and fill the expansion tank to an inch over maximum
    22. start and run the engine until its at operating temperature. check for leaks
    23. once cooled the level in the expansion tank should be on the maximum mark


    doing this will make it run cooler obviously and prevent corrosion. if the system isn't bled properly the air trapped inside will create hotspots and blow the headgasket. its very important this is done right and re done on occaision just to be safe. i do mine every few weeks. another thing to note is aftermarket thermostats run hotter than genuine ones. our temp guage used to sit on 1-2 bars (genuine thermostat) now it sits just under half and warms up a lot quicker (dayco thermostat) we'll see how it goes i may put a genuine one back in cos i only found this out after actually doing it

    11. Injectors: Run some injector cleaner through a tank of fuel and check the electrical connections on top of the injectors. using contact and circuit board cleaner spray the plug and the terminals on the injector, these are prone to corrosion. you'll have to take the intake pipe off the throttle body for easier access to the connections. check the fuel hose clamps on each injector too where it meets the rail, i had a loose one that appeared to be leaking a little. clean it all up and plug the connections back in

    after doing this it appeared to be a bit smoother and there was a bit of a intermittant miss that seems to have disappeared. good to check anyway if you are having some running issues

    12. Oil: to change warm the engine (not too hot) and turn it off. undo the oil cap and undo the sump plug. let it drain then unscrew the filter and remove. replace the sump plug and smear some oil around the rubber o-ring on the new filter. screw the new filter on tight. refill with 20W/50 oil, 4.7L for filter change and 4.3L if not changing the filter. put some lifter free (nulon or similar) in the oil if the lifters are ticking or just for general maintanence to stop it happening. replace the oil cap, run until warm then turn off, let it settle and check the oil level. i do ours every 5000k's and filter every 10000, keeps the lifters from building up sludge and ticking if you do it often.

    13. Ignition Leads: to check the resistance of the leads get a multimeter and set it to the 20K scale resistance. unplug each lead (one at a time makes it easier to remember where they went) and measure the resistance from one terminal of the lead to the other. the gregory's manual states that no lead should exceed 24000 ohms or it needs replacing. also check that the lead isn't cracked or splitting and that the terminals on each end aren't damaged. if one lead is faulty its a good idea to replace them as a set, however they are sold singularly if you just want one.

    If you want something with lower resistance than standard, silicone ignition leads such as top gun are around 7000 ohms per metre and the spiral wound conductor leads have resistances as low as under 1000 ohms per metre (such as Top Gun MAX300).

    14. Engine Control Unit
    TO CHECK ERROR CODES:
    1. remove screw retaining the passenger side kick panel
    2. turn the diagnostic mode selector fully clockwise to diagnostic
    3. start the engine and let it idle
    4. watch the LED's flash (red and green), the red represents tens and the green represents ones (so if the red flashes twice and the green 4 times, thats 24). 14, 23, 24, and 31 should show
    5. drive the car above 10km/h, this will cancel code 14
    6. stop the motor and then turn the ignition to the on position
    7. press the accelerator, this will cancel 23
    8. put the car in neutral, then back into another gear, then back to neutral. this will cancel 24
    9. turn the air con on, then off this will cancel 31
    10. look at the codes that are now displayed, 31 means you dont have air con or its not working and 44 means your air con is working.
    11. any other codes displayed besides this means there is a fault in that section
    12. turn the diagnostic mode selector back full anticlockwise then turn the ignition off.
    13. erase the memory by turning the ignition on, then moving the diagnostic mode selector fully clockwise for 2 seconds, then fully anticlockwise for 2 seconds. turn the key off and the memory is now cleared

    CODES ARE:
    11 Crank angle sensor circuit
    12 Air flow meter circuit
    13 coolant temperature sensor circuit
    14 Vehicle speed sensor circuit
    21 ignition signal circuit
    23 throttle switch circuit
    24 neutral switch circuit
    31 satisfactory operation (non air conditioned models) air conditioner circuit (air conditioned models)
    32 starter signal circuit
    34 detonation sensor circuit (turbo models)
    44 satisfactory operation (air conditioned models)
    Last edited by VL Berlina 5speed; 23-03-2007 at 08:14 PM.

    My Rides

    Project VEE EL
    On the Build.... Full respray, Smooth bay, Clean motor, Turbo, Suspension, Brakes
    Click on the link and tell me what you reckon.

    Yamaha YZ250F
    My 'other ride'

    VY Ute daily.......Dumped on 18s
    The Aussie PackMule

    ___________________________________________

    SA JustCommodore Section
    For Events and Local Stuff Click The Link Above

  2. #2
    Ride
    executive vt 5.0lt

    Join Date
    Feb 2005
    Location
    west suburbs
    Posts
    675

  3. #3

    Join Date
    Mar 2006
    Posts
    28

  4. #4
    SUSPECT's Avatar
    SUSPECT is offline Banned
    Ride
    SUZUKI GSX-R 1000 k8

    Join Date
    Aug 2005
    Location
    adelaide, southern suburbs
    Posts
    1,074

  5. #5
    Ride
    VL 86 RB30 Executive Auto

    Join Date
    Jun 2005
    Location
    South OZ Adelaide
    Posts
    814

    Thumbs up

    Quote Originally Posted by VL Berlina 5speed
    I recently found this on the Street Commodores Fourm and i thought that it was very helpful with common probs on vls, so i thought i will post it to help people have a quick refferance and to help newer members that have common problems.

    credit gose to VL_RACER of Street Commodores for this write up.


    1. Air flow meter: check the connections including rubber boot, clean with contact cleaner if necessary. remove the airflow meter (undo the clamp behind it and remove the top of the airbox and air flow meter together) and clean using contact cleaner or some other cleaner thats safe on electrical components. clean out the airbox and replace the air filter if necessary ($10 for a cheap one, $100 for K&N) reinstall everything

    if the car is stalling after starting or seems to be choking still after this, check AAC valve, air regulator, make sure there's no air leaks, then replace the air flow meter ($20-$60 from wreckers, approx $150 reconditioned, about $400-$600 new)

    TO CHECK AND ADJUST MIXTURE:
    1. start and run the engine until its at operating temperature
    2. set idle speed and timing to specified values
    3. take off the passenger kick panel to view the LED's on the ECU
    4. start and run the motor at 2000rpm for 2 mins
    5. check the flashes from the LED's on the ecu while at 2000rpm, they should both flash together more than 5 times every 10 seconds. if they don't you have ecu or oxygen sensor issues (refer to the picture at the bottom explaining the interpretation of flashes other than what are stated)
    6. if there are more than 5 flashes per 10 secs, stop the engine, disconnect the wiring connector from the AAC valve and the throttle switch
    7. start and run the engine at 2000rpm for 2 mins
    8. let the engine idle
    9. the leds should now flash simultaneously
    10. if the green light is flashing more the mixture is lean, if the red is flashing more the mixture is richer than it should be.
    10. if the LED's do not flash together remove the plug next to the Air flow meter connector and adjust the screw until they flash together (clockwise raises the resistance and leans the mixture, anti clockwise lowers the resistance and richens the mixture)
    11. replace the plug, replace the AAC and throttle switch connectors and return to instruction 4. do the test again to check that the mixture is now right
    12. if the mixture cannot be adjusted so that the leds flash together, its time to test the AFM

    TO TEST AFM:
    pull back the rubber boot on the AFM connector revealing the wires. grab your multimeter and stick the probes on wire 4 (white) and 2 (1 being the closest to the airbox) with the multimeter on DC voltage. turn the ignition on and the voltage reading should be between 1.26V (lean) and 1.32V (rich). this is the base setting and if it is out then the AFM wont be able to be adjusted to a satisfactory mixture (meaning you need a new one)

    and just for interests sake you can test the mixture by putting the probes on wire 1 and 3 with the key on and measuring the voltage. 3.6V is the factory setting which is lean, with 2.0V being rich. the mixture should be in the vacinity of 2.0-4.0i couldn't get the LED's to flash and therefore couldn't set it using the computer so i did it this way and set it to 3.5V (AFM resistance of 375 ohms) and then checked it using the computer and it was right, LED's flashing together.


    2. Throttle body: undo the bolt attaching the intake piping to the throttle cable bracket. undo the pcv valve hose. undo the clamp holding the intake to the throttle body. undo the clamp holding the piping to the air flow meter. clean the throttle body with throttle body cleaner making sure you get all of the black crap out. reinstall intake and clamps and start.

    this will improve throttle response and a tendency to stutter a bit when the accelerator is pressed suddenly


    3. AAC Valve: undo the connector and 2 screws holding it to the plenum chamber. clean the black carbon off the valve with throttle body cleaner. check that the valve has plenty of movement and won't be prone to sticking, this will raise the idle by allowing too much air to bypass the throttle body or stop the flow all together depending where it is stuck. if it is a bit sticky put a little wd40 to make it slide easier. reinstall the valve.


    4. Air regulator: undo the connector and the hose clamps above and below the valve. remove and clean with throttle body cleaner. reinstall

    this will correct warm up running issues and influences the air flow meter so should be done before replacing the air flow meter


    5. Coolant Temperature sensor : check connector and clean if necessary. make sure the earth to the right of the connector is secure.

    this corrects a temp guage that isn't working and a engine that is running rich and using heaps of fuel. if its still running rich it may be the oxygen sensor (approx $200 i think)


    6: Distributor: remove the 2 screws and check the cap and rotor for wear, corrosion and tracking. a pitted rotor connection will need replacing ($10). replace the cap if necessary ($25) also check plugs (starting at $20 a set) and replace if neccessary


    7. Fuel filter: start the engine, remove the fuel pump fuse (#3 i think) and wait for the engine to stall. run the starter to release fuel pressure. put the fuse back in. working under the rear axle remove the clamps and hoses and replace the filter (make sure the flow arrow is the right way).

    this will improve power and smoothness.


    8. Crank Angle Sensor Boot: my boot had fallen to bits allowing water in and causing major corrosion of the terminals and wires and dodgey running one day when it got a bit wet. i've also found that it was the cause of a afm fault code being displayed one day when i ran a diagnostic (its on the same circuit as the afm). a boot and connector kit can be bought for about $15 from repco to fix this problem


    9. Timing: the timing on our vl was 22 degrees btdc when we bought it, meaning it would ping its tits off on regular unleaded but run great on premium. i got it brought back to 17 degrees (15 is standard) and continued to use premium but it then started to run like crap when it was cold (coughing and spluttering on take off until the temp went up). its now on 20 degrees (still with premium) and runs a lot better.

    standard vl's should run 15 degrees on regular unleaded or up to 20 on premium. going over 20 isn't advised because of pinging issues even on premium but then again i'm yet to talk to a mechanic who doesn't think i'm nuts for going up above standard at all.

    TO ADJUST: get yourself a timing light (or borrow one). make sure you get a xenon one cos neon ones aren't worth shit. xenon ones are about $60 from supercheap and about $100 from repco. hook it up (read the instructions that come with it), start the motor and undo the 12mm bolt next to the dizzy. counting the timing marks from left to right on the crankshaft pulley where the first is 0 and the last is 30, move the distributor until you get the setting you want. tighten the bolt and check that the setting is still right. its a good idea to make a mark on the dizzy bolt slider where 15 and 20 degrees are so then you can adjust it yourself between those without having to need a timing light again. check and adjust the mixture after this for optimum results


    10. Radiator/Cooling System: The radiator and cooling system should be flushed every 40,000k's or 2 years and thermostats changed every 2-3 years as well. before you start you should check everywhere for leaks so that you can go and get parts you need before dumping the coolant. common places to look are top and bottom hose housings, hoses, water pump, heater hoses, welch plugs etc. i got the following parts to ensure mine is in good working order:

    - top radiator hose
    - bottom radiator hose
    - top housing
    - thermostat housing
    - thermostat
    - radiator cap
    - silicone sealant
    - tectaloy ultra cool gold (make sure you get coolant suitable for alloy heads)
    - demineralised water
    - hose clamps
    - hose from filler neck to expansion tank

    i'm being very thorough here so all that is absolutely necessary is the coolant and water. now to drop the coolant:

    1. put the heater to the hot position
    2. remove the bottom radiator hose and radiator cap and drain the coolant into a drain tin
    3. remove the cylinder block drain plug (its the lower of the 2 plugs under the exhaust manifold towards the back of the engine). you may need to put some wd40 on this the day before to loosen it up cos they are sticky little buggers
    4. once drained remove all hoses from the radiator, remove the shroud screws and clips on the front plastic piece
    5. lift the shroud up slightly out of the bottom clips and push back over the fan
    6. get some pliers on the radiator clips and remove them, slide out the radiator
    7. block the inlet and reverse flush through the outlet until the water flowing from the filler neck is clean
    8. stand up the radiator and spray it rear to front to wash out any dirt, bugs etc in it
    9. reinstall the radiator
    10. if replacing the thermostat remove the lower hose and thermostat housing (it'll be stuck so lever it out)
    11. pull the thermostat out and clean all around the mounting faces
    12. put the new thermostat in with the jiggle valve to the top and the gasket and silicone sealer
    13. intall the cover and do the bolts up to 29NM (same tightness as plugs)
    14. while waiting for the sealer to set replace the top hose housing, it should come with a gasket
    15. once the sealer has hardened reinstall all hoses and clamps
    16. fill the radiator and replace the cap
    TO BLEED: (vl's need to be bled because the highest water jacket is above the highest part of the radiator)
    18. undo the bleed bolt near the coolant temp sensor
    17. remove the hose going from the filler neck to the expansion tank at the expansion tank end, hold it higher than the bolt hole and using a small funnel, fill until coolant runs out of the bleed bolt hole
    18. reinstall the bolt
    19. remove the bleed bolt on the plenum
    20. fill till coolant comes out as above
    21. reinstall the bleed bolt and hose and fill the expansion tank to an inch over maximum
    22. start and run the engine until its at operating temperature. check for leaks
    23. once cooled the level in the expansion tank should be on the maximum mark


    doing this will make it run cooler obviously and prevent corrosion. if the system isn't bled properly the air trapped inside will create hotspots and blow the headgasket. its very important this is done right and re done on occaision just to be safe. i do mine every few weeks. another thing to note is aftermarket thermostats run hotter than genuine ones. our temp guage used to sit on 1-2 bars (genuine thermostat) now it sits just under half and warms up a lot quicker (dayco thermostat) we'll see how it goes i may put a genuine one back in cos i only found this out after actually doing it

    11. Injectors: Run some injector cleaner through a tank of fuel and check the electrical connections on top of the injectors. using contact and circuit board cleaner spray the plug and the terminals on the injector, these are prone to corrosion. you'll have to take the intake pipe off the throttle body for easier access to the connections. check the fuel hose clamps on each injector too where it meets the rail, i had a loose one that appeared to be leaking a little. clean it all up and plug the connections back in

    after doing this it appeared to be a bit smoother and there was a bit of a intermittant miss that seems to have disappeared. good to check anyway if you are having some running issues

    12. Oil: to change warm the engine (not too hot) and turn it off. undo the oil cap and undo the sump plug. let it drain then unscrew the filter and remove. replace the sump plug and smear some oil around the rubber o-ring on the new filter. screw the new filter on tight. refill with 20W/50 oil, 4.7L for filter change and 4.3L if not changing the filter. put some lifter free (nulon or similar) in the oil if the lifters are ticking or just for general maintanence to stop it happening. replace the oil cap, run until warm then turn off, let it settle and check the oil level. i do ours every 5000k's and filter every 10000, keeps the lifters from building up sludge and ticking if you do it often.

    13. Ignition Leads: to check the resistance of the leads get a multimeter and set it to the 20K scale resistance. unplug each lead (one at a time makes it easier to remember where they went) and measure the resistance from one terminal of the lead to the other. the gregory's manual states that no lead should exceed 24000 ohms or it needs replacing. also check that the lead isn't cracked or splitting and that the terminals on each end aren't damaged. if one lead is faulty its a good idea to replace them as a set, however they are sold singularly if you just want one.

    If you want something with lower resistance than standard, silicone ignition leads such as top gun are around 7000 ohms per metre and the spiral wound conductor leads have resistances as low as under 1000 ohms per metre (such as Top Gun MAX300).

    14. Engine Control Unit
    TO CHECK ERROR CODES:
    1. remove screw retaining the passenger side kick panel
    2. turn the diagnostic mode selector fully clockwise to diagnostic
    3. start the engine and let it idle
    4. watch the LED's flash (red and green), the red represents tens and the green represents ones (so if the red flashes twice and the green 4 times, thats 24). 14, 23, 24, and 31 should show
    5. drive the car above 10km/h, this will cancel code 14
    6. stop the motor and then turn the ignition to the on position
    7. press the accelerator, this will cancel 23
    8. put the car in neutral, then back into another gear, then back to neutral. this will cancel 24
    9. turn the air con on, then off this will cancel 31
    10. look at the codes that are now displayed, 31 means you dont have air con or its not working and 44 means your air con is working.
    11. any other codes displayed besides this means there is a fault in that section
    12. turn the diagnostic mode selector back full anticlockwise then turn the ignition off.
    13. erase the memory by turning the ignition on, then moving the diagnostic mode selector fully clockwise for 2 seconds, then fully anticlockwise for 2 seconds. turn the key off and the memory is now cleared

    CODES ARE:
    11 Crank angle sensor circuit
    12 Air flow meter circuit
    13 coolant temperature sensor circuit
    14 Vehicle speed sensor circuit
    21 ignition signal circuit
    23 throttle switch circuit
    24 neutral switch circuit
    31 satisfactory operation (non air conditioned models) air conditioner circuit (air conditioned models)
    32 starter signal circuit
    34 detonation sensor circuit (turbo models)
    44 satisfactory operation (air conditioned models)
    Top stuff that read
    I was confused now I'm just not so sure!!

    RIP Peter (perfect) Brock....

  6. #6
    VL Berlina 5speed's Avatar
    VL Berlina 5speed is offline Apprentice Panel Pusher
    Ride
    Project VL Show car, VS Exec, VY Ute, YZ250F

    Join Date
    Oct 2005
    Location
    Adelaide
    Posts
    2,684

    Default

    Quote Originally Posted by SUSPECT
    umm did u write all that??? cos thats pretty good man
    did you read any of the post clint??

    first line
    I recently found this on the Street Commodores Fourm and i thought that it was very helpful with common probs on vls, so i thought i will post it to help people have a quick refferance and to help newer members that have common problems.
    just posted it as it was useful

    My Rides

    Project VEE EL
    On the Build.... Full respray, Smooth bay, Clean motor, Turbo, Suspension, Brakes
    Click on the link and tell me what you reckon.

    Yamaha YZ250F
    My 'other ride'

    VY Ute daily.......Dumped on 18s
    The Aussie PackMule

    ___________________________________________

    SA JustCommodore Section
    For Events and Local Stuff Click The Link Above

  7. #7
    SUSPECT's Avatar
    SUSPECT is offline Banned
    Ride
    SUZUKI GSX-R 1000 k8

    Join Date
    Aug 2005
    Location
    adelaide, southern suburbs
    Posts
    1,074

  8. #8
    Ride
    VL 86 RB30 Executive Auto

    Join Date
    Jun 2005
    Location
    South OZ Adelaide
    Posts
    814

    Default

    Quote Originally Posted by SUSPECT
    lol i started reading from tip 10 as thats the only bit i wanted 2 kno
    Did you find it Cozza 88??
    I was confused now I'm just not so sure!!

    RIP Peter (perfect) Brock....

  9. #9
    Ride
    vl berlina wagon 6cyl

    Join Date
    Jul 2005
    Location
    melbourne
    Posts
    928

    Default

    useful info
    if the bleeder bolts havent been undone a while, they may sieze due to corrosion, if they come out, coat the threads with grease, if siezed, I wonder whether penetrating oil or WD40 might free them up?
    cracked heads are very common on VL 6 cly motors from neglecting the bleeder bolts

  10. #10
    VL Berlina 5speed's Avatar
    VL Berlina 5speed is offline Apprentice Panel Pusher
    Ride
    Project VL Show car, VS Exec, VY Ute, YZ250F

    Join Date
    Oct 2005
    Location
    Adelaide
    Posts
    2,684

    Default

    bump.......

    My Rides

    Project VEE EL
    On the Build.... Full respray, Smooth bay, Clean motor, Turbo, Suspension, Brakes
    Click on the link and tell me what you reckon.

    Yamaha YZ250F
    My 'other ride'

    VY Ute daily.......Dumped on 18s
    The Aussie PackMule

    ___________________________________________

    SA JustCommodore Section
    For Events and Local Stuff Click The Link Above

Page 1 of 3 123 LastLast

Similar Threads

  1. step by step manifold making
    By hinterland in forum V6 Development And Modification
    Replies: 114
    Last Post: 28-05-2008, 10:19 AM
  2. The next step... ENGINE MODIFICATION!!!!
    By PaRaDoX in forum VN - VP Holden Commodore (1988 - 1993)
    Replies: 31
    Last Post: 20-09-2006, 01:32 PM
  3. injector cleaning step by step???
    By hold-on in forum VR - VS Holden Commodore (1993 - 1997)
    Replies: 4
    Last Post: 10-09-2006, 03:40 PM
  4. the next step...
    By PaRaDoX in forum VN - VP Holden Commodore (1988 - 1993)
    Replies: 3
    Last Post: 16-07-2006, 09:54 PM
  5. Fixin da front of my vl step by step *pics*
    By ucwepn in forum VL Holden Commodore (1986 - 1988)
    Replies: 31
    Last Post: 17-03-2006, 04:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586 587 588 589 590 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642 643 644 645 646 647 648 649 650 651 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687 688 689 690 691 692 693 694 695 696 697 698 699 700 701 702 703 704 705 706 707 708 709 710 711 712 713 714 715 716 717 718 719 720 721 722 723 724 725 726 727 728 729 730 731 732 733 734 735 736 737 738 739 740 741 742 743 744 745 746 747 748 749 750 751 752 753 754 755 756 757 758 759 760 761 762 763 764 765 766 767 768 769 770 771 772 773 774 775 776 777 778 779 780 781 782 783 784 785 786 787 788 789 790 791 792 793 794 795 796 797 798 799 800 801 802 803 804 805 806 807 808 809 810 811 812 813 814 815 816 817 818 819 820 821 822 823 824 825 826 827 828 829 830 831 832 833 834 835 836 837 838 839 840 841 842 843 844 845 846 847 848 849 850 851 852 853 854 855 856 857 858 859 860 861 862 863 864 865 866 867 868 869 870 871 872 873 874 875 876 877 878 879 880 881 882 883 884 885 886 887 888 889 890 891 892 893 894 895 896 897 898 899 900 901 902