Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

09 3.6L Statesmen Overheating

Nick C

Member
Joined
Mar 26, 2019
Messages
61
Reaction score
0
Points
6
Age
23
Location
Katherine
Members Ride
2007 Holden Commodore VE SS-V Manual
My mate has a 09 Statesmen with 220k on it
Just had oil, waterpump and coolant replaced a week ago.

Drives fine with no problems but then overheats a idle. Fans are engaging and coolant is full.

Any Ideas? Thought maybe faulty Thermostat or Temp Sensor.

Can a can drive ok with a fault thermostat?
 

syked

Donating Member
Joined
Feb 15, 2018
Messages
375
Reaction score
131
Points
43
Age
36
Location
Sydney
Members Ride
2011 WM Caprice
Was the cooling system bled for air after replacing the coolant?

After driving, What do the hoses feel like from the radiator? Are they both hot or cold and are they pressurised or not?

Either way, you shouldn't drive whilst it's overheating
 

Bonus

Member
Joined
Apr 16, 2017
Messages
83
Reaction score
30
Points
18
Age
38
Location
Christchurch, New Zealand
Members Ride
2008 VE SV6
Sounds like there's an airlock/hasnt been bleed properly - why was the water pump replaced?
 

Fu Manchu

Donating Member
Joined
Mar 18, 2006
Messages
8,591
Reaction score
6,096
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
There’s ya problem.
 
Top