Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

185kw chip

greenfoam

New Member
Joined
Jan 13, 2005
Messages
7,902
Reaction score
125
Points
0
Age
99
Members Ride
VP Executive R-spec
yeah it worked a treat on gas
was on the dyno last fri got 120 kw on gas before i tuned it( didnt get a reading after) first run when i got it 98 kw
lost a few kws on petrol(about 7) got 134kw
its a little ritch on fuel atm but ive still gotta do the cam


btw how big did you say it would cope with?(cam wise)
Did you get an air fuel reading on it?, I'd be suprised if you lost power on petrol with that much more timing no matter how rich it was (same dyno?) it should have made the difference between no wheelspin/little wheelspin and mass wheelspin on a full throttle launch too. But yeah it's setup to run say a crane 284 easily just how it is, but that's not an ideal cam for the banana manifold, maybe one of the Wade grinds would be better?

S0sage, yep :)
 

xcop5l

4th year spanner spinner
Joined
Jun 19, 2006
Messages
977
Reaction score
11
Points
0
Location
ol' geelong vic
Members Ride
VN ex cop 5L
Did you get an air fuel reading on it?, I'd be suprised if you lost power on petrol with that much more timing no matter how rich it was (same dyno?) it should have made the difference between no wheelspin/little wheelspin and mass wheelspin on a full throttle launch too. But yeah it's setup to run say a crane 284 easily just how it is, but that's not an ideal cam for the banana manifold, maybe one of the Wade grinds would be better?
i didnt get a a/f reading but i think the rest of my class at tradie did. so ill ask one of them. we were mostly doing gas testing and had the analiser on it.
the dyno is probably majorly out of wack as its at tradie. considering that i did 4 runs on gas and 120 was the highest. when we startied to tune the lpg the dyno computer froze and shut down so we left it.

the first run on when i got it was 141kw and that was at tradie
 
Top