Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

230 000k's service

Joined
Jun 18, 2009
Messages
241
Reaction score
0
Points
0
Location
Gympie
Members Ride
VT calais 1999
spark plugs
leads
coolant flush
oil change
fluid check all round
fuel filter

now its got a lil rough idle so anything u can think of will be great :)
 

madsav

New Member
Joined
Mar 9, 2005
Messages
1,282
Reaction score
5
Points
0
Location
your ass
Members Ride
your ass
did u degrease the engine bay or let any water hit the coil pack? cause that could be the problem
 

EDGE3

New Member
Joined
Feb 20, 2011
Messages
532
Reaction score
2
Points
0
Location
NEWCASTLE
Members Ride
1997 VS COMMODORE,1996 GTS-R COMMODORE
check the coils
 
Joined
Feb 4, 2010
Messages
173
Reaction score
2
Points
0
Members Ride
VT
you could have a dud lead or spark plug,, Also check you leads are on the right plug.
 

Brett_jjj

Well-Known Member
Joined
Oct 16, 2009
Messages
6,805
Reaction score
93
Points
48
Location
Tamworth NSW
Members Ride
vs commodore
If the new plug leads are carbon core silicon type leads,the carbon core can be broken pretty easliy if the leads are kinked or pulled tightly during their installation, once the carbon core is broken,the lead is stuffed.Id also check for a cracked plug,its easy to crack a plug when removing or installing them.Also was the fuel filter installed around the right way with the arrow pointing toward the engine.
 
Top