Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

3.8 ecotec rough idle problem found

01SS

Member
Joined
Feb 26, 2018
Messages
43
Reaction score
6
Points
8
Age
42
Location
Brisbane
Members Ride
VX SS
This post may help someone who is having issues with 3.8 v6 ecotec. I've been having some trouble finding the source of a rough idle in my 03 vy ecotec v6 for some time and have found the issue. It started as just a little burble at idle every now and then and kept getting worse. After changing all the easy items, plugs, leads, coil packs and ignition module, it was still idling like a cammed up ls. The problem was only at idle and fine when driving. After many hours searching the forums I removed the plastic cover and with a tin of throttle body cleaner sprayed around under the plenum until I found a spot where it changed the idle of the motor back to smooth momentarily.
After removing the gasket between the plenum and intake, I found the paint like covering has been cracked and leaking. After replacing the gasket and plenum cover o ring, back to a nice smooth idle.
I hope if someone is having the same problem that this may help too. Only a small crack in the lining but once replaced had my old girl singing like she used to.
 

commodore665

expat Saffa
Joined
Dec 30, 2011
Messages
2,846
Reaction score
2,221
Points
113
Age
52
Location
New Zealand via Cape Town
Members Ride
2005 SV6 & Alfa Romeo 156 V6
This post may help someone who is having issues with 3.8 v6 ecotec. I've been having some trouble finding the source of a rough idle in my 03 vy ecotec v6 for some time and have found the issue. It started as just a little burble at idle every now and then and kept getting worse. After changing all the easy items, plugs, leads, coil packs and ignition module, it was still idling like a cammed up ls. The problem was only at idle and fine when driving. After many hours searching the forums I removed the plastic cover and with a tin of throttle body cleaner sprayed around under the plenum until I found a spot where it changed the idle of the motor back to smooth momentarily.
After removing the gasket between the plenum and intake, I found the paint like covering has been cracked and leaking. After replacing the gasket and plenum cover o ring, back to a nice smooth idle.
I hope if someone is having the same problem that this may help too. Only a small crack in the lining but once replaced had my old girl singing like she used to.
Good write up
 

01SS

Member
Joined
Feb 26, 2018
Messages
43
Reaction score
6
Points
8
Age
42
Location
Brisbane
Members Ride
VX SS
I forgot to mention that another item affected from the vacuum leak was the operation of the fan vents inside not switching between circulating, feet and windscreen settings. Even the gearbox was changing into converter lock up in overdrive a few km/h earlier.
 
Top