Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

5L help

IhateRICE!

New Member
Joined
Feb 26, 2006
Messages
164
Reaction score
0
Points
0
Members Ride
VNSS Atlas Grey
hey all

I did a fault check and i got a code 12.. but the car hasn't been running right for a very long time and a get a code 12 ( Check Passed) i don't get it.

:bang::bang::bang::bang::bang::bang::bang::bang:
 

IhateRICE!

New Member
Joined
Feb 26, 2006
Messages
164
Reaction score
0
Points
0
Members Ride
VNSS Atlas Grey
the car idles really ruff and the tacho is really playing up and it blow alot of black smoke when i've given it a boot full
 

ScoHar

Jizz in my pants
Joined
Apr 10, 2006
Messages
836
Reaction score
7
Points
0
Location
CHCH, NZ
Members Ride
VS Senator
start by resetting the computer, sometimes this can help with rough idle, tacho playing upcould be many things if its jumping all over the place sometimes this means coil, but im pretty sure on these newer cars it comes from the computer which is read from the Crank angle sensor, is the black smoke worse when cold? mine puffs a little black smoke when you boot it.

I would suggest giving the car a service if you haven't already and try some new plugs also.
 

IhateRICE!

New Member
Joined
Feb 26, 2006
Messages
164
Reaction score
0
Points
0
Members Ride
VNSS Atlas Grey
tried new plugs, i got a MSD ignition coil on it now done a service. i was reading somewhere that it could be faulty air flow meter?? where are they located?? front of the intake manifold
 

delcowizzid

on holiday
Joined
Jul 8, 2008
Messages
6,993
Reaction score
437
Points
83
Location
NZ
Members Ride
в∞ѕтεכ √&
VN 5l doesnt have an airflow meter.check the fuel regulator vacuam hose for fuel clean the IAC valve on the throttlebody and the hole it gies in,and after that start looking at the ignition module and the hall effect sensor in the dizzy.also good to check the coolant temp sensor.the ecu has been know to be at fault a lot with issues with richness due to the coolant temp system in the ecu frying alot too.
 

red truck

New Member
Joined
Jan 25, 2009
Messages
44
Reaction score
0
Points
0
Location
just left of hell
Members Ride
VY one tonner / gen3 / 6speed
tacho can short out inside too, causes engine to not run at all eventually. try disconnect it.
 
Top