Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

A duck is stuck in my LS1

electricmonk

New Member
Joined
Apr 28, 2008
Messages
17
Reaction score
2
Points
3
Location
Adelaide
Members Ride
Nothing...Yet
I just bought a WH Statesman LS1 the other day. Has a light intermittent missfire at idle but reading suggests coil packs so will see how that goes.

My major concern at the moment is when I just parked the car I could hear what sounded like the neighbours home alarm. However when I turned off the engine it stopped. Could not get it to make the exact same noise again after. But I did get to hear what sounds like a duck quack noise from around the throttle body area. It makes the sound perhaps five or six times then stops for a while. Im not familiar with the car yet so not sure if the sucking sound I can also hear is from the intake or not. Anyone had something similar before?
 

tml678

Well-Known Member
Joined
Jan 22, 2013
Messages
1,942
Reaction score
1,549
Points
113
Location
Sydney
Members Ride
2017 HSV30 Senator, 2000 Magna
I'd be changing the belt and tensioner as a first port of call.
 

electricmonk

New Member
Joined
Apr 28, 2008
Messages
17
Reaction score
2
Points
3
Location
Adelaide
Members Ride
Nothing...Yet
This is the newest car I have had. Im from old school v8's and air cooled VW's lol. So had to look that up. So im up for a serpentine belt and the tensioner thats mounted on the drivers side head. Will take a better look in the morning. Thanks for the tip
 

tml678

Well-Known Member
Joined
Jan 22, 2013
Messages
1,942
Reaction score
1,549
Points
113
Location
Sydney
Members Ride
2017 HSV30 Senator, 2000 Magna
This is the newest car I have had. Im from old school v8's and air cooled VW's lol. So had to look that up. So im up for a serpentine belt and the tensioner thats mounted on the drivers side head. Will take a better look in the morning. Thanks for the tip
No worries mate, I had a WH LS1 a few years back, loved the bloody thing. Had a very similar issue which I managed to fix by doing what I mentioned above. Not saying it will be the same for you, but it's a fairly cheap fix which is worth having a look at.

Edit - managed to find a pic of the old girl the day I sold it..had a bit of a tear in the eye that day..!
 

Attachments

Last edited:

electricmonk

New Member
Joined
Apr 28, 2008
Messages
17
Reaction score
2
Points
3
Location
Adelaide
Members Ride
Nothing...Yet
Thanks, and yours looked very nice. Love the chrome over the wheel arches. I just sold my WB to get something a little more modern
 

tml678

Well-Known Member
Joined
Jan 22, 2013
Messages
1,942
Reaction score
1,549
Points
113
Location
Sydney
Members Ride
2017 HSV30 Senator, 2000 Magna
Thanks, and yours looked very nice. Love the chrome over the wheel arches. I just sold my WB to get something a little more modern
Thanks mate, I'm assuming the WB was a stato and not the ute? That pic was taken 5yrs ago...before I realised how bad the headlight covers and dodgy chrome grille were lol. The wheel arch covers were ok thankyou, but they dented really easily, I replaced each one at least a couple of times.

But on the upside, she had a mafless tune, pacey tri-y's, an OTR and x-force catback. Something like 170-180rwkw from memory.
 
Top