Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

A few probs with Vy

Boothy

Member
Joined
Mar 26, 2011
Messages
73
Reaction score
0
Points
6
Location
Melbourne
Members Ride
Vn Wagon, VY Commodore
Have a couple of problems with my vy.

Firstly its running a bit rough.
Fluid levels are all good
has had new spark plugs and leads about 12 months ago. Although has overheated a couple of times when the water pump **** itself.
Mass air sensor has being cleaned and new air filter installed.

So due to this can anybody tell me where else i should be looking.

Only ideas i have is putting some injector cleaner in fuel
changing the fuel filter and cleaning plugs. but have no other ideas


Secondly can anybody assist me how i get the centre rear seatbelt reel out as its not retracting and either needs untwisting and some wd40 or it needs replacing altogether.

Any help with this would be apprciated.
 

Futech

Like a boss
Joined
Sep 14, 2012
Messages
241
Reaction score
2
Points
0
Age
48
Location
Auckland, New Zealand
Members Ride
VY 5.7
When's it running rough? Idle? Driving? Could be a lot of things so a bit more info would help. Save your money on injector cleaner its just bullshit in a bottle.
Once you give me some more info ill do my best to point you in the right places.
 

Boothy

Member
Joined
Mar 26, 2011
Messages
73
Reaction score
0
Points
6
Location
Melbourne
Members Ride
Vn Wagon, VY Commodore
When's it running rough? Idle? Driving? Could be a lot of things so a bit more info would help. Save your money on injector cleaner its just bullshit in a bottle.
Once you give me some more info ill do my best to point you in the right places.
Runs a little rough on both driving and idling. Also sluggish on acceleration too.
 

Futech

Like a boss
Joined
Sep 14, 2012
Messages
241
Reaction score
2
Points
0
Age
48
Location
Auckland, New Zealand
Members Ride
VY 5.7
Check for vac leaks first then start going through ignition.
 

Goon

Scientific Tuning
Joined
Feb 20, 2006
Messages
2,508
Reaction score
9
Points
38
Location
BrisVegas. QLD
Members Ride
VY CUSTOM.
Clean your battery terminals to if they look like crap..... if your keen clean the throttle body, inspect the IAC. do what Futech said above!
 

Futech

Like a boss
Joined
Sep 14, 2012
Messages
241
Reaction score
2
Points
0
Age
48
Location
Auckland, New Zealand
Members Ride
VY 5.7
Very common vac pipe is the one running from throttle housing to both rocker covers, any leaks in this and you will have issues big time. Cheap to buy on ebay.
 

Boothy

Member
Joined
Mar 26, 2011
Messages
73
Reaction score
0
Points
6
Location
Melbourne
Members Ride
Vn Wagon, VY Commodore
Thankyou all will check all these things out on my next day off. Anybody got any idea how to get to rear centre seatbelt retractor in the sedan vy ?
 

Mad84VK

New Member
Joined
Nov 17, 2011
Messages
154
Reaction score
0
Points
0
Location
Melbourne
Members Ride
VY S Ute
Coil Pack?
 
Top