Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

A Little Help? (Electric windows)

RocketQueen

New Member
Joined
Sep 20, 2013
Messages
1
Reaction score
0
Points
0
Location
Australia
Members Ride
VX Equipe
Ok, so I'm in the process of fixing the electric windows in my VX commodore as none of them were working for about 6 months. I managed to replace the centre console switches and they work fine now for all windows (although the back 2 are extremely slow). However, the rear 2 switches aren't working at all. The rear drivers side does nothing, and the rear passenger side does nothing when pressed down, but when pressed upwards makes a faint clunking noise even though it's already up.

So, my question is, does this sound like a wiring/motor problem? I wouldn't have a clue where to start to check. I'd rather not have to go to an auto electrician because I flat out don't have the $$$ to spare.

Any help/suggestions would be greatly appreciated.

PS. Sorry if I'm not very clear. I'm not really car-savvy. Please be nice :)
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,266
Reaction score
461
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
The rear switches could be the problem, try changing them over to see if the problem transfers to the other side.
The rear windows are slower than the front.
 
Top