Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

amp troubles

Discussion in 'Car Audio' started by synical, Jul 22, 2006.

  1. synical

    synical New Member

    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Nov 2, 2005
    Location:
    Bankstown, Sydney
    Members Ride:
    VT Executive S2
    hey guys. i just recently installed a new system into my vt consisiting of:

    1 x sony cdx-m8815
    2 x 6" kicker splits
    2 x 6x9 kickers
    1 x 15" cadence sub
    1 x 4x130wrms response precision amp

    the amp was working fine before i installed the splits, and now it doesnt seem to power up anymore. im not really sure on wat i should be looking at.

    any help is appreciated. thanks guys. :)
     
  2. azzfox

    azzfox Braaap.

    Messages:
    1,388
    Likes Received:
    21
    Trophy Points:
    0
    Joined:
    Sep 5, 2005
    Location:
    Yarra Valley, VIC
    Members Ride:
    VE SS-V
    is the protection light coming on? if so check for a short in the speaker wires. have you tried the old speakers again? have you checked gains?
     
  3. synical

    synical New Member

    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Nov 2, 2005
    Location:
    Bankstown, Sydney
    Members Ride:
    VT Executive S2
    well found the problem. remote wire was cut somehow. reattached it and voila problem solved.

    and now for more questions.

    i am currently running my speakers to the hu and sub through the amp.

    1. should i run the amp to the sub out on the hu?
    2. should i consider getting the 2x150wrms response precision amp and run it in bridged?

    again any help is appreciated. thanks guys. :)
     
  4. azzfox

    azzfox Braaap.

    Messages:
    1,388
    Likes Received:
    21
    Trophy Points:
    0
    Joined:
    Sep 5, 2005
    Location:
    Yarra Valley, VIC
    Members Ride:
    VE SS-V
    1. if its for the sub.. yes.
    2. sounds like a good idea then run speakers of the 4ch amp.
     

Share This Page