Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Bad Brakes

jazzawithvg38

New Member
Joined
Oct 20, 2007
Messages
72
Reaction score
0
Points
0
Members Ride
VG Exec
G'day all,
been having troubles with the brakes on my ute,
the problem is that the pedal is really soft and touchy,
only works half the stroke
Has a full hard pedal when engine is not running,
as soon as the engine is fired pedal is not good.
parts replaced so far
brake booster
master cylinder
proportioning valve
new rotors and pad all around
calipers have had new seals installed in front and new calipers in rear.
Any thoughts or suggestion's???????
 

muttley383

Donating Member
Joined
Sep 27, 2007
Messages
170
Reaction score
3
Points
18
Members Ride
VR 383
Since you have replaced nearly everything. As suggested above, the brakes may need a proper bleeding. Do you have ABS?, if so you may need someone with a tech2 so the ABS actuators can be turned on to allow correct bleeding process.
Are you loosing any brake fluid?, do you have a damaged brake hose that may be swelling under pressure?
 

jazzawithvg38

New Member
Joined
Oct 20, 2007
Messages
72
Reaction score
0
Points
0
Members Ride
VG Exec
Yeah bleed the brakes many times Reverse flush ie pushing fluid in,
and convential way. not losing any fluid and no vechile does not have abs,
Cant say 100% that the lines are all good but i have cheched them very closely and they appear normal. Thanks
 
Top