Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Bad crank angle sensor

Turbovg

Member
Joined
Sep 24, 2018
Messages
38
Reaction score
2
Points
8
Age
29
Location
Christchurch
Members Ride
Vg v6 ute
Hey fellas just after some knowledge/ advice a while ago I brought a mazda b2000 ute with a buick 3.8 swap thing was awsome but life happens and i had to sell it,

Long story short i brought it back and now seems to be going through crank angle sensors like tictac’s and idea’s on what could be causing it?

Cheers fellas
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
12,717
Reaction score
6,018
Points
113
Location
North Tas
Members Ride
VE SS Ute Shed Ornament
Are you fitting OEM sensors?
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
12,717
Reaction score
6,018
Points
113
Location
North Tas
Members Ride
VE SS Ute Shed Ornament
Series I VN or series II. Series one need to have the air gap set, pretty sure this changed with series II.
 

Turbovg

Member
Joined
Sep 24, 2018
Messages
38
Reaction score
2
Points
8
Age
29
Location
Christchurch
Members Ride
Vg v6 ute
Update: sent a new crank angle sensor over to be installed being that im away an cant work on it atm and still has no spark

So coils/cpm , cas, still no spark aparntly they had tried another ecu on it aswell but that didnt seem to help anything i am kind of stuck

Its Series 2 also but thinking outside the box here would using a ecu out of an auto on a manual be somthing that could possibly be the issue?
 

Attachments

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
12,717
Reaction score
6,018
Points
113
Location
North Tas
Members Ride
VE SS Ute Shed Ornament
Have you got a code saying failed crank sensor? If yes then it's probably the DFI as it will often throw you the same numbers as CAS, which makes it a bastard at times.
 

Utel67

Active Member
Joined
Jul 15, 2019
Messages
341
Reaction score
144
Points
43
Location
Tasmania
Members Ride
Vs s3 ute
Ecm's are the same so that should be fine.
 

Turbovg

Member
Joined
Sep 24, 2018
Messages
38
Reaction score
2
Points
8
Age
29
Location
Christchurch
Members Ride
Vg v6 ute
Ill have to have a look being that its swapped and not factory im not sure how I would go with doing a code check wether the plugs there to do the old paperclick trick
 

Turbovg

Member
Joined
Sep 24, 2018
Messages
38
Reaction score
2
Points
8
Age
29
Location
Christchurch
Members Ride
Vg v6 ute
Ok so finally got a chance to get my hands on this ute and ive gone through replaced coils/module, balancer & cas, ecu and still no spark hmm im very lost at this point
 
Top