Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

battery light on??

V

vr5l5spd

Guest
Just wondering if anyone had some ideas for me..I have a vr 5l manaul executive and the battery light has been on for the last week and a half. Firstly i replaced the regulator, that didn't work. Then I replaced the complete alternator with one of those revamped jobbies, but the battery light is still on and the battery is not charging.:bang:
Please help..
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,020
Reaction score
89
Points
48
Age
78
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
The wire fron the alt to the battery must be broken or one of your fusible links has burnt out. Get a multimeter and check the cables for continuity. The wire which charges the battery goes from the large terminal on the alt straight to the battery and is always in circuit.
 

JD

Donating Member
Joined
Aug 18, 2006
Messages
1,716
Reaction score
25
Points
48
Age
34
Location
Deep South, SA
Website
www.ccgm.au.tt
Members Ride
1.6L Turbo Holden Croooooooooooze
maybe the recon alternator is broken as well?

as hako says get a multimeter and check anything and everything to do with it.
 

petezor

i like icecream
Joined
Jul 19, 2006
Messages
298
Reaction score
0
Points
0
Members Ride
VS COMMODORE
yeh the alternator , that black module thing that it plugs into is ****ed, happened to mine, put another one in that ****ed up too, so i just got another alternator for $50 instead of wasting money on those module things, and everything is 150% working better :D :p
 
V

vr5l5spd

Guest
yeah i already tested the main wire for continuity and there was a circuit there. The light has just started to come on and then go of again lately too.. weired
Might be time to go to a auto electrician.
 

mitch89

New Member
Joined
Oct 22, 2006
Messages
7
Reaction score
0
Points
0
Members Ride
VN Wagon
does ur engine have a whistle to it when the light is on? kinda like a supercharger whine coming underneath the bonnet... thats whats happening with me... and if im driving normal and then it comes on my lights get brighter and engine loses power and that whistle comes in
 

Berlinarator

New Member
Joined
May 11, 2006
Messages
141
Reaction score
2
Points
0
Location
Canberra
Members Ride
VZ SS-Z
my vr commodore's battery light has been coming on intermittently since it was new... any suggestions there lol?
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,020
Reaction score
89
Points
48
Age
78
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
The whistle comes on when the alternator is charging at maximum rate and if your engine loses power when this happens you have a short somewhere. Most electrical problems can be traced back to bad terminals on the battery - they must be clean and tight.....not just appear clean and tight but remove them, sandapare or wirebrush the contact surfaces, apply some vaseline/silicone/whatever and tighten them up. Also make sure the engine has a good earth to the body. The V6 may be an internal combustion engine but it gets its instructions from an electrical brain...and if that ain't getting the right food as in electricity then it won't act right.....at least thats the way I see it. (did I write that??)
 

JD

Donating Member
Joined
Aug 18, 2006
Messages
1,716
Reaction score
25
Points
48
Age
34
Location
Deep South, SA
Website
www.ccgm.au.tt
Members Ride
1.6L Turbo Holden Croooooooooooze
my vr commodore's battery light has been coming on intermittently since it was new... any suggestions there lol?
alternator prob not charging quite enough.
 

petezor

i like icecream
Joined
Jul 19, 2006
Messages
298
Reaction score
0
Points
0
Members Ride
VS COMMODORE
replace the alternator, i did it with mine v6, got it for $50 for vs one, compared to buying the regulator for it which was about 70odd, dunno how much 5ltr ones are.
 
Top