Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Battery Light

Mupp3ttt

Member
Joined
Jul 29, 2020
Messages
56
Reaction score
3
Points
8
Age
19
Location
Central Coast
Members Ride
V6 VZ Commodore
Hey guys hoping someone may have had the same problem, I have a 1999 vs ute and ever since I’ve owned the car the battery light has been on the dash. I have replaced the battery, alternator twice, the brushes in the alternator and the cluster behind the dash. Not a major issue as tested and everything is working fine. Would anybody have any kind of clue what it could be? For peace of mind I’m absolutely stumped.
 

ephect

Donating Member
Joined
Jul 27, 2006
Messages
5,282
Reaction score
10,512
Points
113
Location
Melbourne
Members Ride
VS Acclaim V6
Sounds like the voltage sense wire is not connected.

It's a separate wire that comes from the alternator. Check around the battery to see if you have a loose wire. I think it has an inline fuse, but can't confirm
 

Mupp3ttt

Member
Joined
Jul 29, 2020
Messages
56
Reaction score
3
Points
8
Age
19
Location
Central Coast
Members Ride
V6 VZ Commodore
I’ve checked the wire that goes from the alternator to the battery, seems to be fine
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
15,727
Reaction score
9,498
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
If the fusible link breaks on the battery it stops the charging. If this was the case then it would result in a flat battery pretty quick. The battery fuse is just a soft brown thin cable of about 8cm.
 

Mupp3ttt

Member
Joined
Jul 29, 2020
Messages
56
Reaction score
3
Points
8
Age
19
Location
Central Coast
Members Ride
V6 VZ Commodore
Alternator is charging correct, battery is normal voltage there aren’t any problems other than having a light on my dash
 

wildfiremaint

Active Member
Joined
Jan 3, 2006
Messages
286
Reaction score
130
Points
43
Location
Sydney
Members Ride
VR SS , 2007 Subaru LIBERTY Wagon
Hi,
12v goes to Battery light on dash and from the bulb goes to regulator on alternator which gnds it if the engine not running or the alternator is not charging. Once engine starts the wire is effectively open circuited by the regulator and the light goes off.
I would suspect that wire is shorting to gnd somewhere along the harness.
Measure ohms to gnd with ignition off.
 

grey_hawk

Active Member
Joined
Jan 14, 2015
Messages
114
Reaction score
80
Points
28
Location
S.A
Members Ride
VR V6 Ute, VS V6 snotbox
X2 short to ground.
 

axemurderer101

Well-Known Member
Joined
Jun 14, 2006
Messages
1,905
Reaction score
152
Points
63
Location
Albany
Website
forums.justcommodores.com.au
Members Ride
VY SS
Unplug the 2pin plug on the alternator, the light on dash should go off. With a test light one pin on the plug should light up with power and the other pin should light up the light on the dash(test light should light up dull).
 
Top