Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

BCM not communicating

StephenM

Active Member
Joined
Jun 26, 2017
Messages
227
Reaction score
43
Points
28
Age
68
Location
Innot Hot Springs Qld. 4872
Members Ride
VS Equippe Series II
I have brought this up before. BCM will not communicate through the OBD port. I checked current and continuity so the wiring from port to BCM seems OK. 12v from power (16) and 5.5v from the BCM. Good earth continuity. However there is only one earth on the port. Every thing I have seen says two. My research suggest a faulty BCM (Snap on Tools documentation). If I get a new BCM does the kay have to be programmed to it or does the key programme to the PCM? The car is running a bit rich and occassional stalls at low revs. I have earthed BCM as suggested inother threads re running rich. Many thanks, Steve
 

woteva

NEED 4 SPEED
Joined
Jul 18, 2005
Messages
1,712
Reaction score
2,324
Points
113
Location
Adelaide S.A.
Members Ride
VE2 Sportwagon - VR2 V6 ecotec Wag - VS2 V6 Wag
What are you connecting to the port ?
You will need an ALDL interface as the VR/VS do not use OBD 1 or 2 protocol.
 

BlackVXGTS

Well-Known Member
Joined
Aug 14, 2004
Messages
4,035
Reaction score
851
Points
113
Location
Melbourne, SE
Members Ride
GEN-F2 GTS A6, VS Clubsport 185 A4
Have you diagnosed using the tried and true "paper clip" method? Also check out the attached pdf files.

 

Attachments

Last edited:

StephenM

Active Member
Joined
Jun 26, 2017
Messages
227
Reaction score
43
Points
28
Age
68
Location
Innot Hot Springs Qld. 4872
Members Ride
VS Equippe Series II
Top