Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Broken Stock Tacho

Discussion in 'VR - VS Holden Commodore (1993 - 1997)' started by RedGoesFaster97VS, Apr 14, 2009.

  1. RedGoesFaster97VS

    RedGoesFaster97VS New Member

    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Feb 18, 2006
    Location:
    Perth,WA
    Members Ride:
    96 VS Executive S II
    Hi guys, My tacho has been broken for a while, it used to flicker all over the place - now its just dead, is there anything i can do to fix it? without having to have it looked at? i have checked fuses under the steering wheel and they are ok, and yes i did search, i see that this is a common problem but no answers, any advice would be helpful.
     
  2. pjdm1980

    pjdm1980 Shut up Jr I'm thinkin!

    Messages:
    2,433
    Likes Received:
    13
    Trophy Points:
    38
    Joined:
    Feb 2, 2009
    Location:
    Geelong, Victoria
    Members Ride:
    E1 GTS BUILD NO# 007, GQ Patrol.
  3. VrWagz1

    VrWagz1 The Wagon on Wheels..

    Messages:
    2,438
    Likes Received:
    27
    Trophy Points:
    48
    Joined:
    May 5, 2008
    Location:
    wollongong
    Members Ride:
    VE SSV MY09 Auto Wagon
    Pull the cluster out and see what you can see i spose as its not a big job. They also pull apart really easy. 5 screws and 3 little brass nuts and you can have the whole cluster apart and the tacho on the bench. If you suspect the tacho itself, check it for dry solder joints ect.... the usual. Then get another for bugger all off ebay and try swapping the tacho out of it into yours.
     

Share This Page