Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Car keeps breakin down

blaze

ridin dirty
Joined
Jul 4, 2006
Messages
610
Reaction score
2
Points
0
Location
bunbury
Members Ride
SILVER BULLET
it keeps breakin down and its got all the sighns of a flatt battery but it aint the problem! she shuts off and the lights are very dimm and has to be jump started just to work and even then i wont get 10kms. the battery light is always on but it aint that coz i bought a new battery last night and yeah i thought it was all sweet got me like 7kms and done the same thing. grrr it wont even click over and dunno what the problem is.. any ideas?
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,020
Reaction score
89
Points
48
Age
78
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
Or the cable that connects to the back of the alternator - quite common for this to fail - if broken then alternator cannot charge battery.
 

JD

Donating Member
Joined
Aug 18, 2006
Messages
1,716
Reaction score
25
Points
48
Age
34
Location
Deep South, SA
Website
www.ccgm.au.tt
Members Ride
1.6L Turbo Holden Croooooooooooze
alternator i reckon
either way get it CHECKED!!!
i damaged my paint on my vp when i was on the yorke penisula one weekend and i had no lights and swiped a tree and scratched my paint.
not happy jan.
 

JD

Donating Member
Joined
Aug 18, 2006
Messages
1,716
Reaction score
25
Points
48
Age
34
Location
Deep South, SA
Website
www.ccgm.au.tt
Members Ride
1.6L Turbo Holden Croooooooooooze
well a seconmd hand one cost me $30 and got it install 4 free
so a new would be probabley be around 75 and labor would cost around that so all up $150 is my guess.
 

Patrio7

3Y3 K4N 5P33K 1337.
Joined
Jul 25, 2005
Messages
1,269
Reaction score
25
Points
0
Age
36
Location
Perth, Como
Members Ride
'96 S1 VS Exec
hako said:
Or the cable that connects to the back of the alternator - quite common for this to fail - if broken then alternator cannot charge battery.
happened to me twice, first cable i found pretty much 1inch from alternator almost perfectly upright, got luck it didnt spark.

second time the made up replacement cable just corroded to ****. but i think its gonna happen even with my new re-terminaled cable. is there some sealing goo of some sort i can use? perhaps some battery terminal protecter. though i think heat is the biggest facter in addition to my cheap non heat resistant cable. need to get some decent gauge stuff that has reallly good resiliant insulation. that or heat shrink.
 

Jamie_87

New Member
Joined
Apr 13, 2005
Messages
467
Reaction score
1
Points
0
Members Ride
2003 BA XR6
you should check the alternators regulator bushes in the back of the alternator, as when they are worn, its dosnt make a connection with the alternator and dosnt charge the battery, therefore car keeps running off battery and dies, one way to check is, if car is on, and battery light is one, hit the alternator with a rubber mallot with decent force and see if battery light turns off or u hear a whirring sound, else u could just pull out the regulator and see how worn the bushes are. I got new regulator bushes from peps for 5 buks. relatively easy job. New alternators can cost upto 350buks and reco ones are like 150-200.
 

stateo 304

New Member
Joined
Jul 29, 2006
Messages
100
Reaction score
0
Points
0
Members Ride
1998 vs serries111 statesman 5.0
u still want those springs kritical???
 
Top