Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Cheaper alternative for VE Wiper Blades

Discussion in 'VE Holden Commodore (2006 - 2013)' started by VS_Pete, Jan 26, 2016.

  1. VS_Pete

    VS_Pete Donating Member

    Messages:
    4,170
    Likes Received:
    5,940
    Trophy Points:
    113
    Joined:
    Dec 23, 2007
    Location:
    Brisbane
    Members Ride:
    VE II SV6 MY12 SPORTWAGON
    In this case ( ACD one) it wasn`t the rubber wiper (which was replaced) it was the plastic blade that holds the rubber wiper.
    In the GM one it is metal blade that holds the rubber wiper.
    So I reckon after 3YRS. the plastic blade in warped.
    I backup this with : new whole ACD blade installed and works right.

    I will still put 303 on the rubber wipers.
     
    lmoengnr likes this.
  2. Fu Manchu

    Fu Manchu Well-Known Member

    Messages:
    1,267
    Likes Received:
    233
    Trophy Points:
    63
    Joined:
    Mar 18, 2006
    Location:
    WA
    Members Ride:
    VZ V6
    Here’s mine being soaked with aerospace 303.
    The green things are sleeves over the blade. Doing it over a couple of days.
     

    Attached Files:

  3. VS_Pete

    VS_Pete Donating Member

    Messages:
    4,170
    Likes Received:
    5,940
    Trophy Points:
    113
    Joined:
    Dec 23, 2007
    Location:
    Brisbane
    Members Ride:
    VE II SV6 MY12 SPORTWAGON
    What do you do next?
     
  4. Fu Manchu

    Fu Manchu Well-Known Member

    Messages:
    1,267
    Likes Received:
    233
    Trophy Points:
    63
    Joined:
    Mar 18, 2006
    Location:
    WA
    Members Ride:
    VZ V6
    Um, put the wiper arms on the car.
    I have the arms off for other reasons.
     
  5. VS_Pete

    VS_Pete Donating Member

    Messages:
    4,170
    Likes Received:
    5,940
    Trophy Points:
    113
    Joined:
    Dec 23, 2007
    Location:
    Brisbane
    Members Ride:
    VE II SV6 MY12 SPORTWAGON
    So the rubbers are dry or do you wipe them and put them on?
     
  6. Fu Manchu

    Fu Manchu Well-Known Member

    Messages:
    1,267
    Likes Received:
    233
    Trophy Points:
    63
    Joined:
    Mar 18, 2006
    Location:
    WA
    Members Ride:
    VZ V6
    LOL Yes, I wipe the wiper blades, let them dry a little and put them back on.

    I do the tops as well.
     
  7. VS_Pete

    VS_Pete Donating Member

    Messages:
    4,170
    Likes Received:
    5,940
    Trophy Points:
    113
    Joined:
    Dec 23, 2007
    Location:
    Brisbane
    Members Ride:
    VE II SV6 MY12 SPORTWAGON
    LOL took me 2 posts to get all the How Too.
    Thanks will give it a go.
     
  8. mike_nofx

    mike_nofx Active Member

    Messages:
    119
    Likes Received:
    38
    Trophy Points:
    28
    Joined:
    Mar 24, 2007
    Members Ride:
    VE SS Sportswagon
    Here’s a little trick I did which made my wiper blades work like new again. I just slid out the rubber blade, then reinserted it the other way around.

    Works amazing now. Previously it wasn’t wiping in the centre section. Good temporary fix anyway.
     
    Dayvo, VS_Pete and Fu Manchu like this.
  9. krusing

    krusing Active Member

    Messages:
    469
    Likes Received:
    130
    Trophy Points:
    43
    Joined:
    Jun 21, 2014
    Location:
    Bayside, Melbourne
    Members Ride:
    2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon
    Where can I get the 3 of them for my Wagon please ?
     
  10. VS_Pete

    VS_Pete Donating Member

    Messages:
    4,170
    Likes Received:
    5,940
    Trophy Points:
    113
    Joined:
    Dec 23, 2007
    Location:
    Brisbane
    Members Ride:
    VE II SV6 MY12 SPORTWAGON
    Holden

    Look at the front page for part numbers.
    Holden and AcDelco
     
  11. krusing

    krusing Active Member

    Messages:
    469
    Likes Received:
    130
    Trophy Points:
    43
    Joined:
    Jun 21, 2014
    Location:
    Bayside, Melbourne
    Members Ride:
    2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon
    I did see the part numbers,
    Is there a particular seller you would recommend, apart from Holden ?
    I did buy a set of front ones, from a Stealer,
    But I recon they were a warranty replacement, because they seemed to be used, but they claimed to be new,
    But when I installed them, they left streaks on the glass, where NEW wiper blades wont do that.
    So I am a bit suspicious of who I buy from now.
     
  12. krusing

    krusing Active Member

    Messages:
    469
    Likes Received:
    130
    Trophy Points:
    43
    Joined:
    Jun 21, 2014
    Location:
    Bayside, Melbourne
    Members Ride:
    2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon
    I have used this seller numerous times, and they are good.
     
  13. VS_Pete

    VS_Pete Donating Member

    Messages:
    4,170
    Likes Received:
    5,940
    Trophy Points:
    113
    Joined:
    Dec 23, 2007
    Location:
    Brisbane
    Members Ride:
    VE II SV6 MY12 SPORTWAGON
    You have answered your own questain.
     
  14. krusing

    krusing Active Member

    Messages:
    469
    Likes Received:
    130
    Trophy Points:
    43
    Joined:
    Jun 21, 2014
    Location:
    Bayside, Melbourne
    Members Ride:
    2002 VY L67 Calais Sedan, 2012 VE L77 Calais Wagon
    Hmm, I didn’t even look for wiper blades from this seller,
    Where I have purchased numerous other mechanical parts/items from them over the last few years.
     
  15. VS_Pete

    VS_Pete Donating Member

    Messages:
    4,170
    Likes Received:
    5,940
    Trophy Points:
    113
    Joined:
    Dec 23, 2007
    Location:
    Brisbane
    Members Ride:
    VE II SV6 MY12 SPORTWAGON
    I only use the GM/Delco for the VE.
    So I can`t comment on other brands for VE.
    I do use Supercheap for one of the VS Wagons.
     
    VE_WagonII likes this.
  16. VE_WagonII

    VE_WagonII Member

    Messages:
    77
    Likes Received:
    16
    Trophy Points:
    8
    Joined:
    Oct 9, 2018
    Location:
    Melbourne
    Members Ride:
    VE Sportswagon
    I bought Wipertech blades for my wagon. The rear window blade wouldn't sit hard against the glass They posted out 2 more replacements, same issue . Ended buying genuine GM, perfect fit no issue.
     
    VS_Pete likes this.
  17. Freddy Kruger

    Freddy Kruger Member

    Messages:
    97
    Likes Received:
    5
    Trophy Points:
    8
    Joined:
    Mar 5, 2005
    Members Ride:
    '09 VE SS UTE
    I put new blades on the SS and the middle of the passenger side wiper still doesn't touch the screen. Do I need to bend the actual arm itself to put more pressure down?

    edit: a slight bend didnt change anything :/
     
    Last edited: Jul 3, 2019
  18. johnni

    johnni Member

    Messages:
    326
    Likes Received:
    2
    Trophy Points:
    18
    Joined:
    Oct 9, 2010
    Location:
    Melbourne
    Members Ride:
    Ve Commodore
    ive got the same problem and its starting to annoy me now. Are your wiper blades genuine or aftermarket ?
     
  19. VS_Pete

    VS_Pete Donating Member

    Messages:
    4,170
    Likes Received:
    5,940
    Trophy Points:
    113
    Joined:
    Dec 23, 2007
    Location:
    Brisbane
    Members Ride:
    VE II SV6 MY12 SPORTWAGON
    Post 113/114/121
     
    Last edited: Jul 8, 2019

Share This Page