Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

"Check Alternator" Warning

meteor7

New Member
Joined
Apr 5, 2009
Messages
2
Reaction score
0
Points
0
Members Ride
VY II
Hey all,

I was just about home this afternoon and the "Check Alternator" warning popped up. It followed with the battery light coming on and the ABS warning firing. About 5-10 seconds later I lost ALL dash lights, radio, speedo, etc. The battery recently came back as a fail when it was tested even though I've had no problems. I've been meaning to change it! Promise! ;)

I got home, turned the car off and restarted. No problems. The check came back as an OK but about 10 seconds after that the same problem hit.

So... my questions are:

1) Could this just be the battery?
2) Could the battery just be a result of something bigger like a buggered alternator?
3) Is it ok to drive to an auto electrician???

Thanks!
 

SAV_117

Donating Member
Joined
Jul 26, 2008
Messages
1,177
Reaction score
11
Points
38
Members Ride
VE V8 Calais
check it with a mutli meter the battry while the car is running if its around 13volts that means the alternator is charging and yea
 

taztassio

Member
Joined
Nov 29, 2007
Messages
297
Reaction score
0
Points
16
Members Ride
VY S L67
i used to cop this every month for a while.

its the regulator on the back. replace it and it should be good.
 

alchemist

VY SS 5.7
Joined
Oct 30, 2006
Messages
8
Reaction score
0
Points
0
Location
Warnbro
Members Ride
VY SS 5.7
I've been having this intermittantly for the past 12 months, seems like going over bumps every now and then disturbs something then it goes funny, at night the lights go dim then come alive again then dim then alive then all is good for another month or two.

Now all went dead completely as of yesterday believe it or not, replaced battery and voltage seems to be at 12.20v when running so its not charging, must be a dodgy regulator.. might go bash it a bit maybe that'll wake it up... how much did your regulator cost you? easy to replace??? cheers
 

SAV_117

Donating Member
Joined
Jul 26, 2008
Messages
1,177
Reaction score
11
Points
38
Members Ride
VE V8 Calais
regulators are easy 2 screws on the back they come out bang new one goes in 2 seconds
 

alchemist

VY SS 5.7
Joined
Oct 30, 2006
Messages
8
Reaction score
0
Points
0
Location
Warnbro
Members Ride
VY SS 5.7
regulators are easy 2 screws on the back they come out bang new one goes in 2 seconds
Thanks mate
Might have to take a looksee tomorrow after work, think the bash plate has to come off, hopefully theres plenty of room to work on it under there, didnt look promising last time I had a look :p
 

SAV_117

Donating Member
Joined
Jul 26, 2008
Messages
1,177
Reaction score
11
Points
38
Members Ride
VE V8 Calais
just realised u had a V8 lol gd luck haha V6 is ten times easier lol
 

CANYONERO

Likes Cheese...
Joined
Mar 29, 2006
Messages
1,028
Reaction score
10
Points
38
Location
Country SA
Members Ride
V8 6spd wif MOMO leavaa.
i thought my Alt died in my VY, when i pulled it out i discovered the B+ wire (alternator to battery) wire was completely cooked for about 30cms from the alternator back. to fix properly you need to replace the loom, but i talked to a auto elec and you can get away with crimping a new section, which is what i did and it fixed the problem. i think loose battery terminals caused it, putting extra strain on the wire.

Thanks mate
Might have to take a looksee tomorrow after work, think the bash plate has to come off, hopefully theres plenty of room to work on it under there, didnt look promising last time I had a look :p
regulator is internal on the GenIII's so its not as easy as a V6 infact i heard a real pain.

you can get the alternator out from the top. i managed. was a struggle but i got there.
 

I8.A4.RE

New Member
Joined
Jan 9, 2011
Messages
123
Reaction score
0
Points
0
Location
ADELAIDE
Members Ride
VY LS1 - LANCER MY10 - VE UTE
Canyonero said:
regulator is internal on the GenIII's so its not as easy as a V6 infact i heard a real pain.

you can get the alternator out from the top. i managed. was a struggle but i got there.


I have this 'CHECK ALT' problem atm with the LS1... Does ^^this mean i have to change the ALT if the REGULATOR is internal...
 

B-Man

Member
Joined
Nov 27, 2013
Messages
318
Reaction score
0
Points
16
Location
SA
Members Ride
VY Calais S2
I'm having same issue in my vy ls1 when under power

if i let it coast everything comes back and battery light goes away

as soon as i put my foot down the littlest bit it happens again

car is 12.7v off
13.2v on idle with HL on
14v on idle with HL off
at 3grand it got to 20v and blew the HL globes

sounds like a regulator issue

is this a new alternator for the ls1?

looks like a prick to change over too, the ecotech are in a nice spot.
is there a how to to remove one of these?
 
Last edited:
Top