Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Code 42,

jakewaze

Jakewaze
Joined
Nov 9, 2008
Messages
136
Reaction score
0
Points
0
Location
Perth
Members Ride
VN Spack S1 Auto
Hi
Since i bought my S1 vn a few months ago the engine light has came on and off throughout each drive. When the engine light is off the car runs REALLY smooth, has plenty of power etc, when the engine light is on it lacks power (probally about 20%less), idles rough and gear changes are harsher and at a higher rpm.
Any way this is a typical drive in the morning. Start the car in the morning and drive to work (5mins) with the engine light off , thats fine, a smooth drive. After work start it up, engine light is always on after work, it lacks power etc etc.
also temperature doesn't seem to affect it. Sometimes when i am driving the car will surge and the engine light will either switch on or off. If the engine light is off and it idles for too long (about 60seconds) at the lights it will usually stall, start it back up and the engine light is on.

Its really confusing me because it will always start straight back up but the engine light will either come on or off.

I have no other parts to use so I would prefer to know what it is b4 buying anything.

Also it is coming up with code 42.

I just had it serviced at automasters (major service) and they just said that it requires further investigation $$$$$

Thanks, sorry if it is a bit confusing lol
 

crazybiker

Member
Joined
Sep 9, 2008
Messages
703
Reaction score
3
Points
18
Location
Sydney NSW
Members Ride
VR Commodore V6
Code 42 - Electronic Spark timing.

Honestly? I'm not to sure what that entails.

But I'm guessing you could have a bad connection or a faulty item with the DFI module, coil packs.
 

Tom_1569

Ecotech Power
Joined
Nov 19, 2006
Messages
2,236
Reaction score
46
Points
48
Location
Gippsland - VIC
Members Ride
'14 SR5 Pusslux
Yeah normally Fauly DFI module or Coil packs, sometimes both if your real lucky lol.

Best thing would be upgrade to a series II DFI Module and Coil pack as its quite common for the Series I to fail.
 

jakewaze

Jakewaze
Joined
Nov 9, 2008
Messages
136
Reaction score
0
Points
0
Location
Perth
Members Ride
VN Spack S1 Auto
hi, thx alot guys, just bought a second habd coil pack and DFI module and it appears to be running fine. I let it idle for a while in drive a few times, rove it really hard then really nice etc and it didn't stall, ::)
 

crazybiker

Member
Joined
Sep 9, 2008
Messages
703
Reaction score
3
Points
18
Location
Sydney NSW
Members Ride
VR Commodore V6
Hope it's fixed mate. I know what it's like. It's a PAIN in the back-side
 
Top