Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

code 46 problems need help

toddk0

New Member
Joined
Jul 19, 2013
Messages
4
Reaction score
0
Points
0
Location
mundaring australia
Members Ride
vr commodore
on my vn I had a code 48 come up so I went and got a new crank sensor but when I was putting it in I had a hangover and didn't realize they'd given me the wrong one till it came up with code 46 and it wouldn't start pulled it out and the middle tooth was fully torn off it had damaged 2 of my teeth on the harmonic balancer so I bent them back went and got they proper one installed it propyl it has good clearance I cleared the code but it still wont start and comes up with code 46 again I've checked the plug and it seems fine any one got any ideas what it could be cause at least when it had code 48 it'd still drive for 5 mins till the check engine light would come on
cheers Todd
 

Cheap6

New Member
Joined
Jun 19, 2005
Messages
2,498
Reaction score
73
Points
0
Members Ride
VP Exec
Codes 46 and 48? Maybe I don't have all the codes but I don't have any reference for those two. What are they meant to be?

The CAS is very sensitive to the gap between the Hall sensors and the teeth on the balancer. Maybe the teeth aren't back in quite the correct position or the CAS is not lined up exactly.

Is there spark? If there is the CAS will be OK because there cannot be spark without it.
 

Brett_jjj

Well-Known Member
Joined
Oct 16, 2009
Messages
6,805
Reaction score
94
Points
48
Location
Tamworth NSW
Members Ride
vs commodore
According to the VN V6and VP V6 workshop manuals, code 48 doesnt even log on these models, it does however log on VR V6 and later V6 models though, and is actually for the camshaft angle sensor, not the crankshaft angle sensor. The camshaft angle sensor is located at the front of the engine, just above the harmonic balancer, slightly to the drivers side.
With the crank angle sensor problem, Id say the balancer is stuffed and not triggering the crank angle sensor, probably because the interuptor blades on the back of it have been bent. The clearances have to be spot on for the crank angle sensor to work correctly. Also Ive seen cheap aftermarket crank angle sensors either fail from new, or fail soon after being fitted, its always best to stick with genuine holden spares when replacing sensors, you pay more for them, but they will usually last for years, "You get what you pay for".
Id get hold of another second hand crank angle sensor from a running engine, just to see if yours will run with that one fitted, as the new one could be faulty..
 

toddk0

New Member
Joined
Jul 19, 2013
Messages
4
Reaction score
0
Points
0
Location
mundaring australia
Members Ride
vr commodore
its a vr with a vn engine and yea the 2 teeth were bent realy bad I tried to get it as close as I can but not sure if its perfect and I don't know any one with a vn I could use the sensor and pulley for abit and its a genuine sensor not aftermarket
 

Brett_jjj

Well-Known Member
Joined
Oct 16, 2009
Messages
6,805
Reaction score
94
Points
48
Location
Tamworth NSW
Members Ride
vs commodore
You might be able to get a secondhand balancer and CAS from a wreckers cheap.
 

toddk0

New Member
Joined
Jul 19, 2013
Messages
4
Reaction score
0
Points
0
Location
mundaring australia
Members Ride
vr commodore
yea I traced the wires back and none of them are burnt out so all I can figure it will be because of the 2 bent teeth it had so im going to go get one tomorrow and hopefully that'll fix it
 

toddk0

New Member
Joined
Jul 19, 2013
Messages
4
Reaction score
0
Points
0
Location
mundaring australia
Members Ride
vr commodore
its not getting any pulse from the sensor I tested that today and went to the wreckers was quoted 88 for a used one so went and asked mechanic how much for one and he told me 80 so just find out how much before going to wreckers so im waiting for the new one to arrive hope it fixes it been nothing but problems scince I put this engine in
 
Top