Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Coil pack

Leebo

New Member
Joined
Feb 12, 2009
Messages
241
Reaction score
1
Points
0
Age
29
Location
Victoria
Members Ride
89 VN
I have something to ask about which may be a potential problem.

I went to repco yesterday and got a coil pack.

I have a 1989 pre september V6 build.
the original coil pack had 3 plugs on one side and 3 on the other.

They gave me an S2 (is mine an S2) coil pack similar one to the VR-VS with the leads all on one side are the packs the same ,would this bea reason for coughing down low when taking off.

I also have new plugs and leads.

any help at all will be useful

cheers guys
 

crazybiker

Member
Joined
Sep 9, 2008
Messages
703
Reaction score
3
Points
18
Location
Sydney NSW
Members Ride
VR Commodore V6
Coilpack shouldn't be the problem.

I've got VR coilpacks on my S1 Commodore.

Have you done an diagnostics check on the computer?
 

delcowizzid

on holiday
Joined
Jul 8, 2008
Messages
6,993
Reaction score
433
Points
83
Location
NZ
Members Ride
в∞ѕтεכ √&
i think you will find you need the S2 DFI module for under the the coils when using the seperate coil packs
 

Leebo

New Member
Joined
Feb 12, 2009
Messages
241
Reaction score
1
Points
0
Age
29
Location
Victoria
Members Ride
89 VN
I need to diagnose the problem's as the CEL is on which delcowizzid has given me help on doing.

It's me from vncommodore.com how you doing?
 

delcowizzid

on holiday
Joined
Jul 8, 2008
Messages
6,993
Reaction score
433
Points
83
Location
NZ
Members Ride
в∞ѕтεכ √&
yeah i knew it was you LOL you find that plug yet
 

Leebo

New Member
Joined
Feb 12, 2009
Messages
241
Reaction score
1
Points
0
Age
29
Location
Victoria
Members Ride
89 VN
Nah i'm gona have a look today for it i'll let you know how it goes.
 
Top