Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Complete electrical shutdown...wtf?

Flange

New Member
Joined
May 14, 2005
Messages
18
Reaction score
0
Points
0
Age
42
Members Ride
VR Commodore
Hey all, just thought id run this by you guys see what you think before i take the car to the mechanics tomorrow.

Driving home tonight in my VC 6cyl Commodore, when mid way through a corner, the car just died. Power steering was gone. Lights, dash, everything dead. Car wouldnt even whimper when i turned the key. Got it towed home but still, not even an interior light goes on and battery is fine.

Now i put it to you guys, WTF is going on!!! :D

Thanks again

P.S Was thinking alternator maybe?
 

jakbob

Lighten up.
Joined
Dec 23, 2008
Messages
201
Reaction score
2
Points
0
Location
Brisbane
Members Ride
VX SS, VC L, VK Vacationer
Sometimes weird stuff like that happens when you have a bad battery connection. I'd be checking all the connections if i were you.
 

ari666

250,000 hits
Joined
Mar 10, 2009
Messages
11,829
Reaction score
119
Points
63
Location
melbourne
Members Ride
1966 impala, R32 GTR
the fuse boxes are inside the car on VC yeah?

cos that happened to me in my VK. there is a plug near the fuse box with about 6 THICK wires in it and it gets brittle. one day it decided to just seperate and ruin my day.

if you have that plug id say look there first

you can easily tell if its an alt problem by disconnecting your batter neg -. if the car continues to run, then switch your lights on. it should be able to run without the battery. if not, then check your connections from Alt+ to battery. i run a new wire anyway cos it cant hurt to have extra copper ;)
 

BENJAMUM

New Member
Joined
Dec 15, 2008
Messages
130
Reaction score
0
Points
0
Age
31
Location
NSW inverell
Members Ride
6.3 ltr blown vy ute & vs 5L ute
that happen 2 me one night had 2 walk 5k 2 me mates place and get him 2 come and give me a jump but i had a bad battery conection can only laught bout it now wasnt at the time lol
 

Flange

New Member
Joined
May 14, 2005
Messages
18
Reaction score
0
Points
0
Age
42
Members Ride
VR Commodore
Hey all,

Just turned out to be the battery connections, really dodgy. Gonna replace em next few days.
Also thinking of replacing all the wiring to alternator and earth while im at it.

Also might look into changing the fuses to a newer unit, or even from jaycar etc...

Thanks again guys :thumbsup:
 

markovr

Well-Known Member
Joined
Nov 23, 2003
Messages
2,979
Reaction score
125
Points
63
Age
59
Location
northside brisbane
Website
www.cardomain.com
Members Ride
07vessv 94vr .04vz wgn,93vp wgn,82 vhV6 wgn 88 vn
At the firewall there is a 3 lug connector near the brake booster that has all the power going inside the car on a large red wire on it ... gets a bad connection on it and you lose everything.
 
Top