Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Cosmos VY SS Ute

pepstar87

New Member
Joined
Apr 27, 2008
Messages
326
Reaction score
0
Points
0
Location
Central Coast, NSW
Members Ride
08 SSV M6
Ride:

2003 Holden Commodore VYII SS Cosmos Purple Ute - 8 cylinder 5.7L LS1

Mods:

SSSL King Springs (R) SSL King Springs (F) with Munroe shocks
20" Shadow Chrome VE GTS Replica Rims with Haida 225/35 tyres
Extractors (unsure on brand)
Single 3" custom exhaust
Calipers painted red
Rear guards rolled

Plans:

OTR & mafless tune
DBA or RDA slotted rotors

Wishlist:

Supercharger kit :)

Pics:

BEFORE






AFTER













When I had the LED tailights in


 
Last edited:

pepstar87

New Member
Joined
Apr 27, 2008
Messages
326
Reaction score
0
Points
0
Location
Central Coast, NSW
Members Ride
08 SSV M6
Ill resize them when my internet is sped up again (its currently at dialup speed because we went over the cap limit)

tailights are no longer in, they didnt suit the car although the leds looked hot at night.
 

VY.abercrombie

New Member
Joined
Feb 15, 2009
Messages
46
Reaction score
0
Points
0
Location
NSW
Members Ride
VY S soon to be SS
looks unreal mate. where abouts you get them rims from and how much if u dont mind me asking?
 

pepstar87

New Member
Joined
Apr 27, 2008
Messages
326
Reaction score
0
Points
0
Location
Central Coast, NSW
Members Ride
08 SSV M6
Straight from bob jane, cost me $2200 with tyres. they are the replicas.
 

pepstar87

New Member
Joined
Apr 27, 2008
Messages
326
Reaction score
0
Points
0
Location
Central Coast, NSW
Members Ride
08 SSV M6
Put the HIDs in, here is a quick pic off my camera phone.

I havent had a chance to play around with them yet and havent experienced them in night yet, but I love the brightness and colour, its 100 times better than halogens.



I still havent found a spot to mount the ballasts and decided what to mount them with (any suggestions? they are quite heavy)

And having problems with one flickering aswell as the high beams and foglights flickering and only the low beams are switched on...!! but am awaiting email from Gerald in regards to this

I read somewhere that it could be the ballast earthing through the chassis creating this problem?
 

pepstar87

New Member
Joined
Apr 27, 2008
Messages
326
Reaction score
0
Points
0
Location
Central Coast, NSW
Members Ride
08 SSV M6
Update -

HIDs are removed, gone back to standard lighting.

Ugly NSW yellow plates are replaced with standard white and black slimlines..looks much better.

SSSLs in rear and SSLs in front are now in!! :D :D :D Love how it sits now, doesnt even ride bad as I thought either, I will clean it up and post pics this arvo
 

pepstar87

New Member
Joined
Apr 27, 2008
Messages
326
Reaction score
0
Points
0
Location
Central Coast, NSW
Members Ride
08 SSV M6
I sent them back.. they looked good but they dont really suit reflector headlights..
 
Top