Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

cruise control-blinkers???

ianf

New Member
Joined
Dec 27, 2006
Messages
85
Reaction score
0
Points
0
Location
Lansvale NSW
Members Ride
99 VS 'S' Utility
:cry:Can someone maybe point me in the right direction?
Anyone who knows me knows I am hopless with anything mechanical, This time however I am clueless?
For some reason my cruise control is not working. I checked the fuse but it's fine but I have noticed that at the same time I lost my cruise control my blinkers stopped turning themselves off after rounding a corner. They sometime turn off and you can hear the clicking and I wanted to know if this might be the cause of the cruise not working?, and if not, what else should I look at?, I'm driving a 99 S ute. Thanks...:dance:
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,209
Reaction score
400
Points
83
Age
68
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2017 Captiva.
I suspect the indicator stalk may be the problem.
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,019
Reaction score
86
Points
48
Age
77
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
As above - maybe the indicator stalk has been dislodged from it's mount - you can drop the panel under the steering wheel to access the switch mount. Disconnect your battery first!.
 

ianf

New Member
Joined
Dec 27, 2006
Messages
85
Reaction score
0
Points
0
Location
Lansvale NSW
Members Ride
99 VS 'S' Utility
Is there anything else I should be looking towards in relation to the cruise control?, I did as you said but couldn't see anything that really seemed out of place?
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,209
Reaction score
400
Points
83
Age
68
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2017 Captiva.
Is there anything else I should be looking towards in relation to the cruise control?, I did as you said but couldn't see anything that really seemed out of place?
Are the cruise control controls on the indicator stalk? I can't remember.
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,019
Reaction score
86
Points
48
Age
77
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
The cruise won't work if a stoplight bulb is blown, or one of the two brake switches are out of adjustment or relay is not working. Does the cruise light come on?
 

ianf

New Member
Joined
Dec 27, 2006
Messages
85
Reaction score
0
Points
0
Location
Lansvale NSW
Members Ride
99 VS 'S' Utility
Cheer's, you were spot on!, it turns out it was a stop light that had blown and as soon as I replaced it the cruise was fine, thanks again...
 
Top