Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Cruise question

ringfeder3

Active Member
Joined
Jul 18, 2005
Messages
363
Reaction score
76
Points
28
Age
53
Location
Nsw
Members Ride
2017 colorado, 94 VR Calais, suzuki gsx1400
The small green light on my cruise control is illuminated but the on switch no longer activates the green CRS light under the instrument panel like it used to...

The cruise control isn't working but the power mirrors are so the fuse must be alright.

Any suggestions?
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
13,291
Reaction score
6,545
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
If is the same as VR then there is s cruise cancellation switch under the brake pedal. The threads strip as they are only plastic. I replaced mine and it sorted the cruise. Same problem you are having.
 

MikeC

Active Member
Joined
Jan 10, 2010
Messages
697
Reaction score
164
Points
43
Members Ride
VQ Statesman
I'd break and clean with contact cleaner the connections in the cruise control circuit. Reassemble with WD40 to help prevent further corrosion. Had a similar problem with my 20 year old MB earlier this week. These cars are getting old and the electrical systems are starting to suffer from problems the manufacturer's never anticipated.
 

_R_J_K_

Well-Known Member
Joined
Dec 20, 2008
Messages
5,937
Reaction score
1,205
Points
113
Members Ride
Zenki S14
Make sure one of your brake lights isn't blown (the lights when you hit the pedal, not the parkers). They do this by design.
 
Top