Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Ecotec Top Swap w/ Mace Air to Air Transient Timing issue

Moosen92

New Member
Joined
Jul 28, 2020
Messages
6
Reaction score
0
Points
1
Age
32
Location
Victoria
Members Ride
VF Commodore Storm
Hi all!

I’ve recently installed the Mace a2a kit, and had Rhys at RK Garage to whip up a flash tune for me, however it seems to want to stall under a quick heavy load, or sometimes when switching from Park to drive.

I have flash tuner pro etc, so rather than posting the ecu back and forth, he could just send me tunes and I could flash them on. We tried adding more/less fuel, to no avail. But he still seems to believe it’s transient fuelling or timing related, (“something in the tune”), rather than anything hardware.

I did change a couple things while installing the A2A and was basically wondering if anyone would have any idea if it might be something more hardware related, or if they might know what I should watch and log on Advanced engine diagnostics, to try and identify the cause of the issue?

I installed the a2a, 60lb injectors, Yellowjacket coils, new Delphi DFI module, Walbro 255 fuel pump, 80° thermostat.

It does also sometimes have issues starting, mostly in the cold, which l believe could be crank angle sensor, and if so, could that also be causing the wanting to stall issue?

Any advice is greatly appreciated.
 

Moosen92

New Member
Joined
Jul 28, 2020
Messages
6
Reaction score
0
Points
1
Age
32
Location
Victoria
Members Ride
VF Commodore Storm
I’ve now replaced:

Fuel filter (Pump was done at the time of top swap)
Fuel Regulator
Battery
Crank Angle Sensor
Idle Air Control Valve
Throttle Position Sensor
o2 Sensors
Tried with original DFI Module and Coil packs
Cleaned Throttle Body

And while the CAS helped it to start more reliably, I’m still experiencing crap starting with rev hunting half the time, and the other half of the time it’ll start fine, but still want to stall under sudden heavy load, or if not stall, have a serious hesitation before catching up and taking off.

At my whits end..
Any help would be greatly appreciated.
 

Immortality

Can't live without smoky bacon!
Staff member
Joined
Apr 15, 2006
Messages
22,891
Reaction score
21,261
Points
113
Location
Sth Auck, NZ
Members Ride
HSV VS Senator, VX Calais II L67
Find someone (tuner) experienced with tuning the L67 with A2A system and go there.

Talk to Barry at Slick sixes. The guy tuning the L67 from Tinshed TV on youtube. He knows the L67 well.
 

Moosen92

New Member
Joined
Jul 28, 2020
Messages
6
Reaction score
0
Points
1
Age
32
Location
Victoria
Members Ride
VF Commodore Storm
I thought I’d chuck the car on tunerpro today, because I’m fairly certain it’s not the tune causing my issue, to search for some codes and made a couple of interesting discoveries.

Code 47 - 18x input missing or grounded

Code 35 - IAC Failure

All things considered, is it crazy to think I may have an electrical issue somewhere in the loom, or maybe even in the ECU?

I took some recordings of the data while trying to start it, and when it eventually started and stayed idling, however it’s not allowing me to upload them here for some reason.
 

Lex

Well-Known Member
Joined
Sep 19, 2012
Messages
6,212
Reaction score
5,683
Points
113
Location
Geelong Victoria
Members Ride
VT Executive S1 V6 6 speed Auto Wagon
I took some recordings of the data while trying to start it, and when it eventually started and stayed idling, however it’s not allowing me to upload them here for some reason.
Pics larger than 2MB?
 
Top