Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

ecu plugs vr holden

go fast

Member
Joined
Jun 13, 2009
Messages
113
Reaction score
1
Points
18
Location
no where
Members Ride
2007 ve ss 6.0 litre
have come across a problem, how do you unplug the plugs from the ecu there are two screws holding a plastic frame/bracket holding the ecu in place,there is one screw on the left side of the frame the other screw is under the second plug that goes into the ecu,i have the first screw out,how do i get the plugs out of ecu to get the other screw out,i have pulled on them and all that stuff but wont budge they dont wont to separate from the ecu, i need to get to the holding the bracket to the car, help me:hmmm::hmmm:
 

Attachments

DJ_Cosmic_Fire

smarter not harder
Joined
Apr 26, 2011
Messages
501
Reaction score
8
Points
18
Location
South East Queensland
Website
www.house-mixes.com
Members Ride
VP S-Pack Oct '91 - VT SrsII Wagon - VE SV6 SrsII
Disconnect negative battery terminal before doing this for starters. Release the clip that secures the ECU main engine loom to the ECU (leave thumb on the release clip) then use a small flat blade screwdriver to gently jimmy the loom plug from the left & right sides of the lug (plus the middle areas of the loom plug). It will loosen up just take your time & don't force it. If you're unsure then take some pics close up & look at them whilst out of the car to know you will be doing it safely.
 
Top