Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Electrical bug

vsdeath

New Member
Joined
Apr 6, 2009
Messages
26
Reaction score
0
Points
0
Members Ride
1995 VS Sedan
Hi everyone

I have a bit of an electrical problem on my VS. I got the engine changed over and noticed when I picked up the car (I was a few hundred kms from the mechanic already) that the rear lights and the lights from the dash were not operational anymore. The stop lights works fine though. I noticed as well that the speed alert display is still backlighted but its not operational as well..

Another problem, maybe related to the first one: I noticed that when I sometimes leave the car parked, the back lights stays on (but dim) even if I took the key out.. So I have to unplug the battery when this occur to avoid loosing the charge over night.

So I'm thinking, there must be a cable or a fuse somewhere that might be buggy or kinked or maybe a harness but I don't have the electrical diagram in mind so if anyone knows well how the electrical network is operating on the VS and knows if there is something that may cause the dash and the rear lights to both go nonfunctional, drop me a line.

Thanks.
 

vsdeath

New Member
Joined
Apr 6, 2009
Messages
26
Reaction score
0
Points
0
Members Ride
1995 VS Sedan
No ideas???
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,020
Reaction score
87
Points
48
Age
77
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
Only things I can suggest is to have a look around where the battery is located and make sure all cables have been re-connected after the engine change-over as it sounds like you have a bad earth somewhere. Next when you notice the backlights on, remove one fuse at a time (and replace) then the next one till the backlight goes out - this will isolate the circuit that's causing the trouble. Also try removing relays one at a time both under the steering wheel and the ones in the engine compartment. Hope that is of some help. Good Luck.
 

vsdeath

New Member
Joined
Apr 6, 2009
Messages
26
Reaction score
0
Points
0
Members Ride
1995 VS Sedan
Thanks I'll try that.. Apparently, there is a bad contact under the steering wheel, that may cause the lights to stay on. Now for the backlights + dash not working, I'll have a look closer around the battery.

Do you know where I could get the full electrical diagram of the vs?
 

vsdeath

New Member
Joined
Apr 6, 2009
Messages
26
Reaction score
0
Points
0
Members Ride
1995 VS Sedan
Thanks I'll try that.. Apparently, there is a bad contact under the steering wheel, that may cause the lights to stay on. Now for the backlights + dash not working, I'll have a look closer around the battery.

Do you know where I could get the full electrical diagram of the vs?
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,020
Reaction score
87
Points
48
Age
77
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
Gregorys has 13 pages of diagrams which is a bit much to Email. Public libraries hold manuals which you can borrow. However PM me your email address and I can send what I think are the most relevant pages.....probably engine, interior and exterior illumination.
 

Ice101

Member
Joined
Nov 5, 2008
Messages
32
Reaction score
0
Points
6
Location
Taupo
Members Ride
VS Clubsport
From memory the dash lights and tail lights (excluding brake lights) are on the circuit so you may have a blown fuse for that particular problem.
 
Top