Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Emission Engine Fault

Neva Ierace

New Member
Joined
Oct 9, 2019
Messages
1
Reaction score
0
Points
1
Age
68
Location
Sydney
Members Ride
VE SV6
I have a 2007 VE Ute. An engine fault keeps coming up every time I start the engine. This was originally intermittent ( over a couple of years )and my mechanic would clear it for me. As it became more constant he tried to isolate the problem. All the computer would say is that it was an emission issue. Eventually he changed one of the catalytic converters. It did not solve the issue. He explained it could be many things and very difficult to pin point. He suggested taking it to Holden as they might have a more detailed read out. After 1.5hrs of diagnostic testing Holden service said the oil pressure switch was faulty. I had the switched changed by my mechanic but after 3 days the fault reappeared. I’m back at Holden again. They say it’s not the computer and they are also struggling to pin point the fault. Anyone else come across this issue?
 

syked

Donating Member
Joined
Feb 15, 2018
Messages
371
Reaction score
128
Points
43
Age
36
Location
Sydney
Members Ride
2011 WM Caprice
do you have more details around what DTC's were presented when CEL comes on?
 

Fu Manchu

Well-Known Member
Joined
Mar 18, 2006
Messages
7,876
Reaction score
5,229
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
Holden and your mechanic should have the codes written/printed on the invoice/report some where.
 
Top