Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Engine knock

Craigrizzy

New Member
Joined
Mar 29, 2011
Messages
5
Reaction score
0
Points
0
Age
29
Location
Busselton
Members Ride
VT s-sport 5spd
Made it to work yesterday morning somehow, by the time i get there it was shocking and the car was knocking and shaking like it was about to stall, and had no power. Similar to taking off in 3rd or 4th. Left at work and started today and ran fine for about 20 mins, coolant levels are all fine etc, any ideas please!
 

edals

Well-Known Member
Joined
Sep 30, 2008
Messages
1,907
Reaction score
57
Points
48
Location
Here
Members Ride
VE Equipe
I Thinking the Crank angle Sensor mate since it ran fine when you left work.
 

Craigrizzy

New Member
Joined
Mar 29, 2011
Messages
5
Reaction score
0
Points
0
Age
29
Location
Busselton
Members Ride
VT s-sport 5spd
Whats that worth, i was gonna change spark plus and leads tomoro and drop the fuel just and fuel filter just incase it got some bad fuel, worth a shot? Its probably more than due anyway.
 

edals

Well-Known Member
Joined
Sep 30, 2008
Messages
1,907
Reaction score
57
Points
48
Location
Here
Members Ride
VE Equipe
Yeah I would do a Full service over it first.
Plugs, Leads, Air/fuel/oil filter and some good oil.
But a Good way to test the Crank angle sensor, when it plays up, throw some water on the sensor and see if it goes fine again for a few mins before it heats up again.
Think they are about $80
 

Craigrizzy

New Member
Joined
Mar 29, 2011
Messages
5
Reaction score
0
Points
0
Age
29
Location
Busselton
Members Ride
VT s-sport 5spd
Only reason i dont think its the crank sensor is that i left it nearly 8 hours yesterday and it still knocked, yet today it started fine after a good 24 hours, could it be the computer, maybe disconnect terminal leads and let it sort its self out, but yes, think i will give it a good overhaul tomorrow! Hoping its just some bad fuel
 

edals

Well-Known Member
Joined
Sep 30, 2008
Messages
1,907
Reaction score
57
Points
48
Location
Here
Members Ride
VE Equipe
One of those hard things to find, my vy misses once or twice on the was to work, done everything now thinking coil packs :(
 

Craigrizzy

New Member
Joined
Mar 29, 2011
Messages
5
Reaction score
0
Points
0
Age
29
Location
Busselton
Members Ride
VT s-sport 5spd
After reading im thinking pcv as when i checked plugs today the back d/s plug was a absolute mess, and im assuming as it heats up it would make it nearly impossible to spark, i just found that someone resolved the problem with new leads and plugs, so for 100 or so bucks its my best bet i think, as i have joked around and pulled a plug cap off mates cars a couple of times and its pretty similar symptons.
 
Top