Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Engine noise/throttle body

Discussion in 'VT - VX Holden Commodore (1997 - 2002)' started by vuTobySS, Mar 30, 2011.

  1. vuTobySS

    vuTobySS New Member

    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Jun 24, 2010
    Location:
    Qld, Gold Coast
    Members Ride:
    VU SS 5.7L LS1 2002
    Hey guys just bought a SS inductions 78mm throttle body and fitted it. I found out that colant ran through the bottom of my orginal one and have bypassed that. Looking on the forums i have seen that people say its just to prevent it sticking with freezing but just wanted to ask as not 100% sure.
    I found my old throttle body the control flap in the middle one of the star screws was loose and the control flap could move around, hopping this is what was causing my accelerater to stick after hard acceleration (or as it was more frequently, burnouts :p)
    I have also found that a tapping/nocking noise comming from my engin bay has stoped, maby it was the losse control flap in the old throttle body?
    The other thing i wanted to say was that in my stock throttle body when i pulled of the colant it came out with a fair amount of pressure, posible that hadent let car sit for long enough but i noticed that the first 2-3 seconds of discharge was dirty/rusty looking and that the metal conection on the bottom of the stock throttle body was cloged with rust. I tryed to blow through it and it woulnt budge!
    I just thought it was worth mentioning, any info would be nice.
    Thanks Toby.
     
  2. EDGE3

    EDGE3 New Member

    Messages:
    532
    Likes Received:
    2
    Trophy Points:
    0
    Joined:
    Feb 20, 2011
    Location:
    NEWCASTLE
    Members Ride:
    1997 VS COMMODORE,1996 GTS-R COMMODORE
    Why did coolant run through it,the throttle body is part of the air intake,air should run through it not coolant
     
  3. vuTobySS

    vuTobySS New Member

    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Jun 24, 2010
    Location:
    Qld, Gold Coast
    Members Ride:
    VU SS 5.7L LS1 2002
    It dosent run through the throttle body as such, it runs through a conection bilt into the bottom of it, rang mechanic and asked and he confermed its to stop it freezing shut in cold climates
     
  4. vuTobySS

    vuTobySS New Member

    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Jun 24, 2010
    Location:
    Qld, Gold Coast
    Members Ride:
    VU SS 5.7L LS1 2002
    Bloody car is doing it agian. New throttel body didnt so **** all >.>
    What would be making my car rev to high? or get stuck at high revs.
    Over this!!!!
     
  5. graham7773

    graham7773 Active Member

    Messages:
    1,043
    Likes Received:
    12
    Trophy Points:
    38
    Joined:
    Oct 6, 2008
    Members Ride:
    VT Acclaim Wagon
    Have you checked your throttle cable for any sticking?
     
  6. vuTobySS

    vuTobySS New Member

    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Jun 24, 2010
    Location:
    Qld, Gold Coast
    Members Ride:
    VU SS 5.7L LS1 2002
    how do i check for that?
    when i open the throttel body manualy its fine....but thinking of that maby i should get a mate to sit in there and pump the pedel for me. It its sticking how do i fix that?
     

Share This Page