Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Engine oil life

Discussion in 'VE Holden Commodore (2006 - 2013)' started by PTRSEN, Dec 19, 2010.

  1. PTRSEN

    PTRSEN New Member

    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Aug 23, 2010
    Location:
    Diamond Creek
    Members Ride:
    VE SIDI SV6 UTE
    took the ute to holden a few weeks ago for its 15000K service. checked the engine oil life on engineering mode before hand and it was at 7%, so obviously needed changing. picked the car up and it was still at 7% but i thought it might take abit of driving for the computer to register the change. so its been two weeks and its now down to 3%. i'm no mechanic but i checked the dipstick and it looks like fairly new oil (i think) and it says on service report oil change. so why isnt it registering on the computer?
     
  2. greenacc

    greenacc Searching for the billion

    Messages:
    4,988
    Likes Received:
    719
    Trophy Points:
    113
    Joined:
    Jul 13, 2008
    Location:
    Sydney
    Members Ride:
    VE Berlina
    The oil life counter should be reset by the mechanic, yours obviously didn't bother. They think you don't know about engineering mode so they don't bother to reset the oil life thinking you won't notice. You can relax though as they would have still changed the oil. Your best bet is google it, how to reset oil life, its similar to resetting service reminder, very easy, so easy i'd expect better from Holden. Restet it yourself and you're away.
     
  3. PTRSEN

    PTRSEN New Member

    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Aug 23, 2010
    Location:
    Diamond Creek
    Members Ride:
    VE SIDI SV6 UTE
    no worries thanx mate
     
  4. lease1

    lease1 New Member

    Messages:
    203
    Likes Received:
    1
    Trophy Points:
    0
    Joined:
    May 11, 2006
    Members Ride:
    SSV Ute
    To reset engine oil life in engineering mode, turn ignition so the reds are on, dont start it, and press accelerator three times quickly. Oil life will be reset to 99%
     
  5. jdodd

    jdodd New Member

    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Jun 14, 2009
    Location:
    sa
    Members Ride:
    Vn Berlina
    the reason why the oil life would not have been reset is because it is not used for anything in this market. it may be used in saudi or the us. the ecu won't do anything with the information and neither will the instrument panel. its just there. so holden mechanics don't really bother with it. why waste time on something most every day customers don't see.
     
  6. RiCeY

    RiCeY F O R U M W A R R I O R

    Messages:
    4,126
    Likes Received:
    441
    Trophy Points:
    83
    Joined:
    Mar 29, 2005
    Location:
    Australia
    Members Ride:
    VZ SV8 6spd 6.0 470rwhp
    Correct jdodd.
     
  7. Jacko84

    Jacko84 Member

    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    16
    Joined:
    Aug 14, 2010
    Location:
    Girrawheen
    Members Ride:
    VS Berlina soon to be 5L
    interesting
     
  8. affinity

    affinity Member

    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Joined:
    Jan 1, 2010
    Members Ride:
    International (Dual Fuel) VE MY10 Sedan, 3.6L 4A
    This does not work for me. My mechanic guided me through resetting service reminders, but it isn't a service reminder item -- now at 5% just after 15k service. I actually replaced the oil at 5k at my mechanic, but didn't bother with resetting the oil life then. I expected it to reset for the 15k service though.

    Not sure if MY10 software is different, but does anybody know how to reset oil life for this one? My car is dual fuel (factory), the "instant fuel" doesn't work, but the dealer said that was normal for factory dual fuel cars.
     
  9. UFO

    UFO I Believe

    Messages:
    1,860
    Likes Received:
    18
    Trophy Points:
    38
    Joined:
    Oct 29, 2009
    Location:
    Canberra
    Members Ride:
    MY10 VE International Sportwagon SIDI 3L
    i have a MY10 and oil reset works for me fine.

    turn key to ON (but not starting the car), press go pedal fully to the floor 3 times (doesnt have to be quick... just has to be flat to floor each time), then turn key to OFF.
    next time you start, oil should be 100%.

    if this doesnt work, maybe its got something to do with the dual fuel.... but unlikely.
     
  10. ads18x

    ads18x New Member

    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    0
    Joined:
    May 20, 2010
    Location:
    SW Sydney
    Members Ride:
    MY10 SV6 Ute
    wont work for me, dont know whats wrong
     
  11. greenacc

    greenacc Searching for the billion

    Messages:
    4,988
    Likes Received:
    719
    Trophy Points:
    113
    Joined:
    Jul 13, 2008
    Location:
    Sydney
    Members Ride:
    VE Berlina
    Doesn't the process need to be completed within 3 seconds ? Reds, push push push, off. done. Thats what i read on the net somewhere and it worked for me.
     
  12. affinity

    affinity Member

    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Joined:
    Jan 1, 2010
    Members Ride:
    International (Dual Fuel) VE MY10 Sedan, 3.6L 4A
    Thank you, but it still doesn't work for my car. :(
     
  13. MPRSSV

    MPRSSV Donating Member

    Messages:
    68
    Likes Received:
    2
    Trophy Points:
    0
    Joined:
    Oct 7, 2008
    Location:
    Campbelltown, NSW
    Members Ride:
    05 VZ Exec (Police pack) & 05 CV8Z Monaro
    Not having a go at you but when Holden want $260 for a basic service I know I would want them to do EVERYTHING properly...
     
  14. RiCeY

    RiCeY F O R U M W A R R I O R

    Messages:
    4,126
    Likes Received:
    441
    Trophy Points:
    83
    Joined:
    Mar 29, 2005
    Location:
    Australia
    Members Ride:
    VZ SV8 6spd 6.0 470rwhp
    Seeings the oil life feature isn't used in Australia then doing a service without resetting it is doing everything properly.

    Or would you prefer we adjust your headlights to suit American roads?
     
  15. ads18x

    ads18x New Member

    Messages:
    51
    Likes Received:
    1
    Trophy Points:
    0
    Joined:
    May 20, 2010
    Location:
    SW Sydney
    Members Ride:
    MY10 SV6 Ute
    do you get a reminder or something on the screen if it gets to 0%, even if you have service and have that reminder taken off?
     
  16. richmond2000

    richmond2000 New Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Mar 21, 2010
    Location:
    winterpeg Canada
    Members Ride:
    VE G8 V6
    in Canada OnStar will E mail you a monthly report and on it it will report the oil life + the car will tell you to change the oil @ 5% I believe, and my dealer did NOT reset it ether
     
  17. arronm

    arronm Active Member

    Messages:
    827
    Likes Received:
    120
    Trophy Points:
    43
    Joined:
    Dec 15, 2008
    Location:
    Perth
    Members Ride:
    FPV F6 VF Redline WGN
    When my oil life went to 0% the sump plug unscrewed its self and dumped the oil. Those on 3 - 5 % should be worried.
     
  18. 07GTS

    07GTS Well-Known Member

    Messages:
    1,807
    Likes Received:
    376
    Trophy Points:
    83
    Joined:
    Sep 8, 2013
    Location:
    Australia
    Members Ride:
    VEGTS BLOWN E85
    99% of mechanics dont reset the oil life after a service so it probably sits at 0 for ages... simple to do yourself...
     
  19. GSG

    GSG New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Aug 21, 2017
    Location:
    NSW
    Members Ride:
    Commodore VE Exec
    G'day Riey, thanks for your previous response, re 6sp ve transmissions.
    On this topic, I have mine @ 13% oil life & I have tried to reset it, as per this method & holding down the enter key again for long time periods, I have tried all combinations of all other buttons as well & it wont reset. I do notice as I turn the key to the off position I get a quick flash message of 'press enter to reset' as the screen dies.
    It is an SV6 2011 series 11 VE sedan 6sp 3.8L
    Any ideas please?
     
    Last edited: Aug 7, 2018
  20. redvxr8clubby

    redvxr8clubby Active Member

    Messages:
    843
    Likes Received:
    152
    Trophy Points:
    43
    Joined:
    Jan 5, 2015
    Location:
    Sunshine Coast QLD
    Members Ride:
    VX Clubsport R8 & VE SS
    So just checking your process. You are in Engineering Mode, you scroll down to Oil Life, it shows percentage. Press the accelerator 3 times flat to the floor - wait a few seconds it should change to 100%, if not repeat. I just tried this on my 2009 VE SS, oil life was showing 0% then it reset to 100%.
    As has already been said in this thread, this is just a counter that presumably just counts the Km down from 15,000 expressed as percentage (so presumably would show 50% after 7500 Km etc, not sure if it may also factor in time, for example if you haven't driven the car for 6 months after changing the oil, would it also show 50%? The car does not sense the actual oil quality. If you log your oil changes and know the kms when it was last changed, there is no particular benefit to resetting this counter.
     

Share This Page