Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Engine swap, motor clanging... Where did it go wrong? Stuffed piston?

CHA53R

New Member
Joined
Aug 28, 2010
Messages
294
Reaction score
0
Points
0
Location
vic
Members Ride
vr wagon
hi there, i baught a vn series 2 donor car for my vr commodore, motor was quiet and ran great in the vn.. found out that didnt work in my vr so had timing cover camset and timing chain changed to make it work in my series 2 vr as it has a cam sensor... my transmission is on the way out but left it in as the motor change cost me $950 2 motors out 1 put in and parts change over. picked it up yesterday. had start up problems thought ok needs new plugs and leads. drove it 35kms home.. had a play on the highway to see how it went and ran good.. 160kms no probs... went to take it out today and theres clanging coming from the motor at the back, could it be the transmission at all or a stuffed piston? how would it run if it is a stuffed piston? or could it be a bearing problem? any insight? cheers..
 

Brett_jjj

Well-Known Member
Joined
Oct 16, 2009
Messages
6,805
Reaction score
87
Points
48
Location
Tamworth NSW
Members Ride
vs commodore
It might be something simple like a faulty starter not retracting away from the flex plate.Id start by looking at it.There will be some sort of marks on it if thats the cause.
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,020
Reaction score
87
Points
48
Age
77
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
I'd agree with Brett that it sounds like the starter/ring gear. Also maybe the exhaust manifold loose/hitting body. Why not take it back to where you got it fixed up at.
 

CHA53R

New Member
Joined
Aug 28, 2010
Messages
294
Reaction score
0
Points
0
Location
vic
Members Ride
vr wagon
i did, he reckons the flex plate and everything are tight as. and doesnt have a clue what it is.. he said maybe piston.. mind you he's a inbred looking backyard wrecker... lol i thought if it was a piston it would drive like crap. but drives better than my old engine when it was running good... also has some sort of ignition problem as the idle is up and down and screetches sometimes too when you turn the key to start it, like when you turn the key when the motor runs and you turn the key the wrong way and it goes rrrrrrrrrrrrrrt lol i changed the plugs to the ones off my old motor which are only 1000km old and didnt make much difference. also noticed park doesnt lock straight away rolls a little bit then clunk locks in. my transmission is stuffed but not that stuffed... and at around 100kms it sort of stumbles along when you put the foot down on it drives good but... so not sure if its the tranny doing it... either he has stuffed something up or iv swapped a dud for a dud in the way of motors... motor ran perfect when it was in the vn but..
 

db_notso

diagnostic technician...
Joined
Oct 2, 2010
Messages
979
Reaction score
7
Points
0
Age
33
Location
sunshine coast, qld
Members Ride
vt v6, mods(susp brakesetc...)
+1 loose flex plate to tourque converter bolts
makes loud metal clang noise when on off acceleration
tghiten those buggers up

screeching noise could be loose flex plate to crank bolts.. (box out)
or loose starter motor
or starter different size teeth? not sure if they changed flex plate at all in models
or damaged ringear or starter teeth

if motor ran good before then something hasnt been fitted correctly

check engine earth is tight as well as some basics like battery terminals etc before going too crazy
 

CHA53R

New Member
Joined
Aug 28, 2010
Messages
294
Reaction score
0
Points
0
Location
vic
Members Ride
vr wagon
its not noticable while driving its more on idle and when the revs are low.. sort of sounds like an old diesel engine....
 

db_notso

diagnostic technician...
Joined
Oct 2, 2010
Messages
979
Reaction score
7
Points
0
Age
33
Location
sunshine coast, qld
Members Ride
vt v6, mods(susp brakesetc...)
okay then
start engine
disconnect injectors one at a time and see if knock goes away
(plug back in then check next one)
when you find out which cylinders are KNOCKING you know the fault is in that cylinder or its system parts

if all are the same could be an oil pressure issue
do an oil pressure test

e.g. check plug tight in hole, next for me would be a compression
1st: check dry cylinder
2nd: next one with a few ml of oil in there (wet test) this may help you figure out if its a valve problem or a piston to bore problem

if compression is good and no fault found but noise goes away when undoing injector
likely to be a problem with piston to pin or rod to crank clearance like a spun bearing
you would be unlucky for this to happen but better to know then not

NOTE: taking the injector off removes the compression preasure from that cylinder another way is to remove plug lead
anything to stop combustion on one cylinder at a time but i like injectors as no sparkie sparkie ow ow :)
 

pjdm1980

Shut up Jr I'm thinkin!
Joined
Feb 2, 2009
Messages
2,434
Reaction score
14
Points
38
Location
Geelong, Victoria
Members Ride
E1 GTS BUILD NO# 007, GQ Patrol.
If it didn't do it in the other car then it's bound to be a fitting problem and from the sounds your describing it's a starter or loose flywheel, good luck.
 

MR.HG

Donating Member
Joined
Dec 12, 2010
Messages
177
Reaction score
12
Points
18
Location
Brisbane
Members Ride
HG Brougham, VS Ute, VR SS
aww man that sux..... is this 'mechanic' guy a friend or friend of the family etc? ( i assume he isnt family cos you referred to him as inbred ) i love it when they try to palm it off as something that makes it hard to check......did he even go over it again for you? put it up on the hoist? or just talk bullshit to you and ask you put your bonnet up while he listens with a puzzled look on his face? fvckin cowboys man, ruin the trade for everyone else...im sure you did your job properly to earn the money to pay him to begin with.....you would think he would do the right thing to earn his money but unfortunately this is not the case......situations like this make me mad mate i hope you get to the bottom of it
 

James39

Gave up on VL's
Joined
Jul 21, 2009
Messages
1,029
Reaction score
2
Points
38
Location
Newcastle NSW
Members Ride
1995 VS Acclaim & 1992 Holden Barina
Mine ran like that, but went away after the second oil change.. I do suggest replaceing your starter motor as sounds like it could be on it's way out.....
 
Top