Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Fault Code P2189

Discussion in 'VE Holden Commodore (2006 - 2013)' started by Astro12, Aug 13, 2018 at 1:35 PM.

  1. Astro12

    Astro12 New Member

    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Jul 31, 2012
    Location:
    Central Coast
    Members Ride:
    Vx Executive S1
    Hi All,

    My 08 Berlina with 150000 has just thrown up it's very first fault Code, didn't really want to go to the mechanic to pay $100 for a scan so I bought a OBD tool on special at Supercheap, pretty cool by the way.

    It has spat out system to lean confirmed on bank 2 pending on bank 1. I've taken all of the info and cleared the codes.

    Yesterday I installed a new air filter. The only one in stock was K&N and seeing as I needed it desperately I bought it. Could this have something to do with it putting out those codes? My old air filter was just that, old so I have noticed that the car is driving better with the new one in. Only difference would be a very very minor rough idle.
     
  2. lmoengnr

    lmoengnr Well-Known Member

    Messages:
    1,522
    Likes Received:
    631
    Trophy Points:
    113
    Joined:
    Jan 15, 2012
    Location:
    Sunbury Vic.
    Members Ride:
    MY12.5 Maloo R8, MY12 Redline ute, Magnum 224
    After you cleared the code, has it come back?
     
  3. Astro12

    Astro12 New Member

    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Jul 31, 2012
    Location:
    Central Coast
    Members Ride:
    Vx Executive S1
    Yep, happened again on the way to work this morning. System too lean at idle bank 1 & 2 confirmed. Going to try a standard filter to see if that corrects it.
     

Share This Page