Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Fixing a Trip Computer

MikeC

Active Member
Joined
Jan 10, 2010
Messages
698
Reaction score
164
Points
43
Members Ride
VQ Statesman
I believe it will. I purchased a set of LED's (for their long life) for the LCD's but didn't use them as I wanted to keep the original dimming feature. From memory I checked the wiring diagrams before I made this decision. Working with all the brittle plastic components needed to replace the LCD lighting is not something I want to do too often.
 

MikeC

Active Member
Joined
Jan 10, 2010
Messages
698
Reaction score
164
Points
43
Members Ride
VQ Statesman
Bit late but I've just done this on another cluster and the tripmeter LED's don't dim or cut out in a VQ with the dimmer adjustment on the RH switch "ears".
The whole cluster, including the LCD display area does dim with the adjuster because the 3 incandescent cluster lights controlled by the dimmer set the overall cluster light level- the tripmeter LED's keep working but are simply too small to matter.
 

Roo Ute

New Member
Joined
Nov 20, 2021
Messages
1
Reaction score
0
Points
1
Age
50
Location
NSW
Members Ride
VG 5L Ute
Jumping on an old thread here. I’ve got a VG that’s had some mods done prior to me getting it. Has had a level 3 cluster fitted with what looks to be a VP dash and full wiring loom complete with climate control. Was a V8, now I’ve put a V6 in it. So far almost everything works except for the lcd screens. No odometer is my biggest concern. Any way to check if the screens have died?
Cheers
 

MikeC

Active Member
Joined
Jan 10, 2010
Messages
698
Reaction score
164
Points
43
Members Ride
VQ Statesman
Jumping on an old thread here. I’ve got a VG that’s had some mods done prior to me getting it. Has had a level 3 cluster fitted with what looks to be a VP dash and full wiring loom complete with climate control. Was a V8, now I’ve put a V6 in it. So far almost everything works except for the lcd screens. No odometer is my biggest concern. Any way to check if the screens have died?
Cheers
Check the ribbon that powers the screen is securely plugged in. I'd unplug it , clean it with contact cleaner , then plug it back in.
 
Top