Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Fuse for the dash lights keeps blowing

cypher967

HSV VT 5.0 195i
Joined
Jul 5, 2005
Messages
229
Reaction score
0
Points
0
Location
Adelaide
Members Ride
VS Commodore S
Everytime put a new 7.5amp fuse in for the dash lights number 5 i think it is, keeps blowing. I turn the lights off put in the new fuse turn the lights back on and the fuse is dead i changed it 4 times and the same thing happens. any ideas anyone??
 

VL Berlina 5speed

Apprentice Panel Pusher
Joined
Oct 3, 2005
Messages
2,684
Reaction score
30
Points
0
Age
32
Location
Adelaide
Members Ride
Project VL Show car, VS Exec, VY Ute, YZ250F
shorting out somewhere
i had a simular problem with mine 2 years ago which i found two probs


the two cables on the sliders for the ac had warn the cables down and shorted out on each other

also the dash dimmer switch, this can arc sometimes melt the wiring so it blows
 

jatsvl

NEEDS MORE POWER!
Joined
Nov 21, 2006
Messages
959
Reaction score
17
Points
0
Location
Adelaide
Members Ride
vl exec wagon
fuse #4 is parkers and dash, check your park light relay and that your tail/headlights are not full of water.
 

mrcommy

New Member
Joined
Jun 13, 2009
Messages
4
Reaction score
0
Points
0
Members Ride
VX Executive S2
did u just install the stereo? if so id say u hooked the park lite wire up to ur earth on the stereo. if not have u got a trailer socket.
 

cypher967

HSV VT 5.0 195i
Joined
Jul 5, 2005
Messages
229
Reaction score
0
Points
0
Location
Adelaide
Members Ride
VS Commodore S
All fixed now the dash lights was the cause auto electric fixed it up.
 
Top