Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

GLUGY CHANGE TRANSMISSION

Discussion in 'VE Holden Commodore (2006 - 2013)' started by countrylife, Oct 21, 2019.

  1. countrylife

    countrylife Member

    Messages:
    41
    Likes Received:
    4
    Trophy Points:
    8
    Joined:
    Aug 26, 2019
    Location:
    Cairns QLD
    Members Ride:
    Holden Commodore VE SV6 2008 Sedan 3.6L
    My 2008 VE Commodore auto , what's happening, when pull put pd driveway then just go to take off Every Time I hear a clicking pop sound when the transmission changed? It's not very loud but it's bugging me. Fluid levels of trans has been checked and cleared. The cluncking/clicking/popping sound only happens when first accelerating. Though when going down a hill it has a sick change like a slight pullback, hard to explain. Coasting along at 80 km or more no problem. Could this have anything to do with engine mounts? How would I know if engine mounts not good other then getting a mechanic to check. Having much trouble finding an honest reliable mechanic in my area, that's the trouble
     
  2. commy vk

    commy vk Active Member

    Messages:
    506
    Likes Received:
    76
    Trophy Points:
    28
    Joined:
    Oct 20, 2009
    Location:
    South Coast Region
    Members Ride:
    commodore ve
    Been hearing a lot lately about shonky mechs
    I reckon if you find a good one stick to him/her.
    The bad one wouldn't last long anyway as word of mouth often rules.
     
    countrylife likes this.

Share This Page