Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Hazards turn on and off randomly vs commodore

KeRaizee

New Member
Joined
Jun 14, 2012
Messages
22
Reaction score
0
Points
0
Location
Melbourne
Members Ride
VS S Pack 3.8 Ecotec
i have a vs commodore, and the hazards turn on randomly, i have checked all fuses, and wiring, nothing wrong, but once when i put new reverse lights in, my left indicator would stay on while pressing the brake, eventually it stopped doing it, but the hazards have been going on and off since around that time, (i had to force the light in abit) i don't know if not using the right light causes that to happen, but any help would be good thanks guys
 

MYVESSV8

Well-Known Member
Joined
Nov 28, 2009
Messages
3,073
Reaction score
318
Points
83
Location
Brisbane/GoldCoast
Members Ride
VE 6LT M6
hazards normally go on and off!!

seriously though, check and clean your hazard swich, all indicators are wired through this, check your earth connections at the light also
 

Juan

New Member
Joined
Aug 22, 2008
Messages
61
Reaction score
0
Points
0
Members Ride
A Commodore
It could also be a faulty relay in the body control module which is right above the brake pedal in my VZ . I have a similar problem with the left blinker staying on intermittently after locking and unlocking the car . Flattened my battery a few weeks ago .
Look up my post on " left blinker staying on " and the good guys on this forum told me how to fix it . In my VZ I think the same relay controls hazards and blinkers after locking the car but don't quote me on that as I'm not the expert . It may be a similar fix in your model.
This may or may not help http://forums.justcommodores.com.au...6-left-blinker-staying-after-locking-car.html
 

KeRaizee

New Member
Joined
Jun 14, 2012
Messages
22
Reaction score
0
Points
0
Location
Melbourne
Members Ride
VS S Pack 3.8 Ecotec
Thanks guys any more ideas to solving this??
 

MYVESSV8

Well-Known Member
Joined
Nov 28, 2009
Messages
3,073
Reaction score
318
Points
83
Location
Brisbane/GoldCoast
Members Ride
VE 6LT M6
relay for these is in main fuse panel r/h side kicker, doesn't run through bcm that I know of, flasher is under dash by steering wheel i think
 

Juan

New Member
Joined
Aug 22, 2008
Messages
61
Reaction score
0
Points
0
Members Ride
A Commodore
relay for these is in main fuse panel r/h side kicker, doesn't run through bcm that I know of, flasher is under dash by steering wheel i think

I think you are refering to left / right turning flasher control but I was refering to how the blinkers are also connected to the BCM for signaling , lock and unlock of the car . Two seperate circuts that can both energise a blinker light . When my left blinker stays on if I wack the BCM module it goes off .
Usually I just hit the key again and it goes off the next lock cycle . I may be wrong but I think both areas could cause the problem in some form.
 

MYVESSV8

Well-Known Member
Joined
Nov 28, 2009
Messages
3,073
Reaction score
318
Points
83
Location
Brisbane/GoldCoast
Members Ride
VE 6LT M6
I think you are refering to left / right turning flasher control but I was refering to how the blinkers are also connected to the BCM for signaling , lock and unlock of the car . Two seperate circuts that can both energise a blinker light . When my left blinker stays on if I wack the BCM module it goes off .
Usually I just hit the key again and it goes off the next lock cycle . I may be wrong but I think both areas could cause the problem in some form.

tend to agree with you there, both area's could be the issue, did the op fix it havent heard?
 
Top