Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

5ltr_vp_bt1

New Member
Joined
Dec 21, 2016
Messages
3
Reaction score
0
Points
1
Age
20
Location
New South Wales
Members Ride
5ltr vp executive bt1
Hey Guys I have a 92 5ltr vp and one day I was driving it pretty rough and than all of a sudden it started to backfire and pop as we drove it so when I start it up now it starts misfiring and it starts popping and banging checked leads and plugs they all spark, swapped injectors over and the same cylinders still don't fire also checked pushrods and rockers seem fine, ran out of ideas on what it could be haven't checked any sensors (o2 sensors, map sensors, maf) could that be it any help would be greatly appreciated
thank you,
 

hi_ryder

Donating Member
Joined
Aug 27, 2008
Messages
3,352
Reaction score
103
Points
63
Location
Pascoe Vale South, MEL
Members Ride
vp calais ls1, vp berlina 3.8L
try doing an error code check. 9/10 times with the 5L's its ignition module related, technology in those things is like 25 years old. theres mobs that reco them with new guts, new technology. communicating your problem through a computer screen can only go so far though. it could be a bunch of things.
 

strgas

GRA = REAL HP
Joined
Oct 23, 2009
Messages
1,503
Reaction score
61
Points
48
Location
3666
Members Ride
MERC W124 / toys WB tonner WB Panelvan project
checked fuel pressure ??
 

5ltr_vp_bt1

New Member
Joined
Dec 21, 2016
Messages
3
Reaction score
0
Points
1
Age
20
Location
New South Wales
Members Ride
5ltr vp executive bt1
I'll go down and get it engine codes read tommorrow and have them check the fuel pressure too! I'm hoping its just a split vacuum line or something along those lines
 
Top