Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

help i'm going nuts trying to find the problem - solved !

skookumchuck

New Member
Joined
Feb 12, 2009
Messages
40
Reaction score
1
Points
0
Members Ride
'04 vy s series 2
Thanks every one for your input. After 3 AFM's problem was solved after one that wasn't stuffed worked okay ! The trouble is that it was off a car that was running and now i need to seach for a good one. expensive exercise that ! cost about $600 all up plus buying another car ! originally it was the distributor and putting it back 180 degrees out made it backfire and blew the heat wires out ! from there my troubles began. ah well all good experience. thanks again black as, panama, detox_nath83, social,, treezy, woodytoad, goon. couple of you guys were right on the ball with the AFM.
cheers
 

skookumchuck

New Member
Joined
Feb 12, 2009
Messages
40
Reaction score
1
Points
0
Members Ride
'04 vy s series 2
Mate not a worry thats what we are all here for.
Glad your back on the road :)
Bloody AFM's and CAS
yeah, it just runs a bit rough on idle and when you put your foot down it hesitates a bit. but i'll fiddle around with that. i'm just glad it's going. i think maybe the timing although it's on 15 degrees. i'll put it to 17* and see how it goes.
cheers
 

detox_nath83

Another VL Driver
Joined
Aug 6, 2005
Messages
2,160
Reaction score
6
Points
0
Age
37
Location
Queensland(Sunny Coast)
Members Ride
VL Turbo Commo
Engine Stutter...... Hesitant
Clean Throttle Body
Plugs.....Clean or replace
Leads......Replace
AAC Valve on Plenum clean make sure inner rod moves freely
Injector Cleaner
Clean dizzy/Rotor
Change Fuel Filter
C how u go Bud
no air leaks in intake piping
wd40/Inox or contact cleaner on contacts for CAS and AFM, Power Transistor, Injectors,Clean Oxy Sensor and spray contacts. :p
 
Last edited:
Top