Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Help please i am a victim of the cross 8

veight man

New Member
Joined
Jun 22, 2010
Messages
20
Reaction score
0
Points
0
Members Ride
VK Berlina
hey guys i seriously need some help, my cross 8 auto transmission karked it. i have no 4th gear, i still have gears 1,2 and 3, but they are slipping big time...and the other funny thing is there is no light coming up...it keeps saying the system is ok...wtf...does anyone think its a small problem or is it what i think it is....F&%$ed up? its either electircal or mechanical...i seriously think it could be bloody both and the whole transmission is worn out....please help
 

nick_

Member
Joined
Dec 21, 2006
Messages
173
Reaction score
2
Points
18
Members Ride
VY II V6
Have you checked the trans fluid condition and level yet? It might just need a top up of fluid.
 

Dr HaxZaw

New Member
Joined
May 6, 2010
Messages
1,462
Reaction score
11
Points
0
Location
Sydney
Members Ride
R34 GT-T
yeah my parents had a mitsubishi van... cant remember what its called but it was slipping like crazy... asked my dad and it had never had the auto gearbox serviced in 200,000ks.... nearly lost my **** right there lol... anyway got it serviced by a mechanic and the oil was apparently a sludge but now its driving like normal... if youve looked after yours then id be taking it to a mechanic who knows what hes talking about
 

db_notso

diagnostic technician...
Joined
Oct 2, 2010
Messages
979
Reaction score
7
Points
0
Age
34
Location
sunshine coast, qld
Members Ride
vt v6, mods(susp brakesetc...)
if the fault is MECHANICAL e/g/ worn bands then no light will come up UNTIL it cant AT ALL physically select a gear as picked up by the output speed sensors....
if fluid isnt milky due to blown trans cooler in radiator then time for a rebuild.. sorry man...
 

veight man

New Member
Joined
Jun 22, 2010
Messages
20
Reaction score
0
Points
0
Members Ride
VK Berlina
Have you checked the trans fluid condition and level yet? It might just need a top up of fluid.[/QUOTE

i have checked the level quite alot and it reads the same all the time. but i havent checked the trans fluid condition...i am not sure how to check that one...i will ask my bro. thank you heaps
 

veight man

New Member
Joined
Jun 22, 2010
Messages
20
Reaction score
0
Points
0
Members Ride
VK Berlina
i really hope i will have the same problem lol
 

veight man

New Member
Joined
Jun 22, 2010
Messages
20
Reaction score
0
Points
0
Members Ride
VK Berlina
thanks fella for explaining the whole light thing...i really hope it is that....ive booked it in for early next week at the mechanics..so i hope i dont have to do a rebuild...i think that would ultimately piss me off...cheers
 

VTPREDATOR

New Member
Joined
Jan 19, 2006
Messages
484
Reaction score
4
Points
0
Age
35
Location
Warwick
Members Ride
VE SS SPORTSWAGON
have a smell of the fluid. if it smells burnt, its a good sign that it time for a rebuild
 

RiCeY

F O R U M W A R R I O R
Joined
Mar 29, 2005
Messages
4,126
Reaction score
467
Points
83
Location
Australia
Members Ride
VZ SV8 6spd 6.0 430rwhp
have a smell of the fluid. if it smells burnt, its a good sign that it time for a rebuild
LOL! Fluid smelling burnt simply means its due for new fluid.
 

soop

Banned
Joined
Nov 11, 2008
Messages
3,847
Reaction score
58
Points
0
Location
Smithton, Tasmania.
Members Ride
2003 SS Commodore Series II
if the fault is MECHANICAL e/g/ worn bands then no light will come up UNTIL it cant AT ALL physically select a gear as picked up by the output speed sensors....
if fluid isnt milky due to blown trans cooler in radiator then time for a rebuild.. sorry man...
LOL, Puts a light on when you're sitting on the side of the road free reving... That's almost as useful as the oil pressure light in a HQ....
 
Top