Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Help - VP cuts out when driving and then won't start for a number of hours

gully

New Member
Joined
Mar 22, 2009
Messages
2
Reaction score
0
Points
0
Members Ride
VP Executive
I have a VP that I bought new - it has about 150k on the clock. It's generally in excellent condition and has been serviced regularly. Recently it's started cutting out when driving, and then usually won't start again for a number of hours. The mechanics I've taken it to for years are baffled. They replaced the ECU and for 6 weeks it performed perfectly until the trouble returned. They thought it might be the engine immobiliser and have by-passed it. The car performed perfectly for another six weeks and then the problem returned. They've now replaced the crank angle sensor but aren't convinced that's the problem.

Any ideas? If the problem can't be solved I'm going to have to get another car. Any help appreciated!
 

gdunkley84

I Have a Dent.
Joined
Jan 12, 2005
Messages
79
Reaction score
1
Points
8
Age
37
Location
Orelia, WA, 6167
Members Ride
2009 VE SSV Sportswagon
The CAS was the problem with mine. Would drive along fine, then get hot and shutdown. After a little when it cooled a bit it would start fine again.
 

Not_An_Abba_Fan

Exhaust Guru
Joined
Aug 18, 2006
Messages
14,413
Reaction score
938
Points
113
Location
Bunbury, WA
Members Ride
Strange Rover
Next time it cuts out, pour some water on the CAS and try starting it again. If it starts, it is definitely the problem. But I see it has already been replaced....
 

88GreenVN

Next Exit Left
Joined
Jun 12, 2006
Messages
6,795
Reaction score
133
Points
63
Age
57
Location
Surprise, Arizona
Members Ride
Dodge Ram Van 1500 5.2 V8
Not all new CAS's are good quality. I'd also check the wires that go to the cas - give em a wriggle while running.

Not starting for a while after it stalls - points to a heat related issue. And this is generally the CAS or DFI. How's the DFI unit?
 

88GreenVN

Next Exit Left
Joined
Jun 12, 2006
Messages
6,795
Reaction score
133
Points
63
Age
57
Location
Surprise, Arizona
Members Ride
Dodge Ram Van 1500 5.2 V8
Good point ^^^ when it stalls and refuses to start - is the fuel pump buzzing away at all?
 

gully

New Member
Joined
Mar 22, 2009
Messages
2
Reaction score
0
Points
0
Members Ride
VP Executive
Thanks for the help folks. Might be the CAS Not_An_Abba_Fan - that's the last thing that's been replaced so perhaps with a bit of luck that will have cured the problem. Re DFI unit 88GreenVN don't know what it's like. Mechanics seemed to think that a fault would knock out power to two cylinders - not the lot - or perhaps I'm getting mixed up with the coil pack. The odd thing is that when the problem occurs, the car won't restart for a long time. When it's happened late afternoon, it won't even start two or three hours later but always will by the next morning. Oddly enough as well, I'm sure that when it happens the car has always been decelerating and perhaps turning - coincidence perhaps. If it happens again 88GreenVN I'll listen for the full pump - good suggestion. Thanks again all.
 

gdunkley84

I Have a Dent.
Joined
Jan 12, 2005
Messages
79
Reaction score
1
Points
8
Age
37
Location
Orelia, WA, 6167
Members Ride
2009 VE SSV Sportswagon
Re DFI unit 88GreenVN don't know what it's like. Mechanics seemed to think that a fault would knock out power to two cylinders - not the lot - or perhaps I'm getting mixed up with the coil pack.
The DFI is the board that the coil packs themselves sit on. And if it goes all 3 packs would stop working.
 

gully

New Member
Joined
Mar 22, 2009
Messages
2
Reaction score
0
Points
0
Members Ride
VP Executive
Thanks gdunkley84. I'll check out with the mechanics whether they've replaced the coil packs. I suspect that the problem is non-heat related given the symptoms. I assume issues with the DFI aren't necessarily heat-related.
 

paulforaname

Member
Joined
Dec 12, 2008
Messages
44
Reaction score
0
Points
6
Members Ride
VS SS
i have same problem my vs ss will not start when driven for awhile and then fires and now starting to cut out when revs drop and wont restart for 30 mins , had fuel pump changed and no better.
 
Top