Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Help with engine problem

Discussion in 'VL Holden Commodore (1986 - 1988)' started by Yaw, Nov 27, 2017.

  1. Yaw

    Yaw New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Oct 10, 2017
    Location:
    South Australia
    Members Ride:
    VL Commodore Berlina
    So my engine is idling pretty rough sounding like it’s basically going to shut off but doesn’t, still drives but I don’t want to drive it the way it is but atm it’s my only source of transport has this happened to anyone else randomly haven’t changed anything, I can upload a video later, it’s just a regular RB30 N/A
     
  2. lmoengnr

    lmoengnr Well-Known Member

    Messages:
    1,210
    Likes Received:
    446
    Trophy Points:
    83
    Joined:
    Jan 15, 2012
    Location:
    Sunbury Vic.
    Members Ride:
    MY12.5 Maloo R8, MY12 Redline ute, Magnum 224
    It might be your Idle Air Control valve clagged up with carbon, and stuck in the base idle position.
     
  3. Yaw

    Yaw New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Oct 10, 2017
    Location:
    South Australia
    Members Ride:
    VL Commodore Berlina
    Would you have any idea how I’d check that and how much it’d cost? Thank you for the reply
     
  4. chrisp

    chrisp Active Member

    Messages:
    173
    Likes Received:
    58
    Trophy Points:
    28
    Joined:
    Dec 9, 2009
    Members Ride:
    VF2 SS Redline
    Just as a general suggestion, pop the bonnet when it is dark and see if there is any arcing from and ignition leads, the coil or distributor.
     

Share This Page