Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Hey guys wondering if this ticking noise is lifter problem or cam problem any ideas?

Trent1818

New Member
Joined
Oct 23, 2018
Messages
2
Reaction score
0
Points
1
Age
30
Location
Port nacquarie
Members Ride
Ve ss ute lime green
Hey fellas I have a 2008 VE Ss ute it's hot a few mods like exhaust and cam but I've been away awhile and it hasn't been started for a year or so and when I drove it last halfway through the drive it started this noise.
I've been told it's the lifters off people but also that's its the cam of others.. Anyone have any ideas?
I can't upload it to the site so I put it on YouTube and added the link.
Thanks.
 

Dylan kingswood

Active Member
Joined
Dec 5, 2017
Messages
133
Reaction score
67
Points
28
Age
31
Location
Hobart
Members Ride
2011 s2 Ve ss
Yeah I wouldn’t be revving it sounds similar to mine when a lifted failed and it ended up scoring cam where the roller chewed itself out, personally I’d be pulling rocker covers and going from there working my way down , what’s oil level like ? Where the dod lifters replaced for ls7 ones ? Springs upgraded to suit cam ?
 

Dylan kingswood

Active Member
Joined
Dec 5, 2017
Messages
133
Reaction score
67
Points
28
Age
31
Location
Hobart
Members Ride
2011 s2 Ve ss
Actually scrap that first look at extractor gaskets just noticed you had extractors which if they have gaskets on them they are notorious on the ls motors for blowing out I just seal them with permatex with no gasket
 
Top