Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

High Beam on VK SL

booma11

New Member
Joined
Oct 7, 2006
Messages
7
Reaction score
0
Points
0
Location
Adelaide Hills, SA
Members Ride
253 VH Vacationer
OK, now this is gonna sound like a really stupid question...

I have just bought an 85 VK Commodore SL and I am wondering how to turn on the High Beams and keep them on :embarrass . I can get them so that they flash but they won't stay on, they just go back to low beams. Is there some secret way of engaging them :confused: (I haven't owned a holden before) or is my indicator Stalk stuffed.

Cheers, Stuart
 

vkberlina

VK Madman
Joined
Mar 12, 2004
Messages
3,518
Reaction score
41
Points
48
Age
41
Location
NSW Central Coast
Website
www.members.westnet.com.au
Members Ride
VK EFI 5L, VK 134 Pack, LX8 Adventra, MF35 & MF50b
No Stupid Questions at all. Welcome to the forum.

All you do is pull the indicator stalk back towards the steering wheel and high beam _should_ engage. If it only flashes odds are your indicator stalk is stuffed.


cheers
Scott
 

booma11

New Member
Joined
Oct 7, 2006
Messages
7
Reaction score
0
Points
0
Location
Adelaide Hills, SA
Members Ride
253 VH Vacationer
OK Thanks.

I did go to install a brand new one, but it fried itself when I was testing it. Annoyingly the warranty statement on the back says it has a 6 month warranty but does not cover burnt wires!! :ranting:
 
Top