Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Holden VE commodore 2007 | Timing chains...

Discussion in 'VE Holden Commodore (2006 - 2013)' started by StealthyBrayden, Jul 30, 2012.

  1. StealthyBrayden

    StealthyBrayden New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Jul 30, 2012
    Location:
    Melbourne
    Members Ride:
    Holden VE commodore 2007
    Just a question..
    Do timing chains need to be replaced after 100,000km's in a Holden VE commodore (2007)...?
    Thanks
     
  2. wesky

    wesky New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Jun 13, 2010
    Members Ride:
    '07 VE Omega
    No. However, there have been multiple issues with timing chains throwing error codes. Searching the forum will assist.
     
  3. Alex05

    Alex05 Member

    Messages:
    182
    Likes Received:
    3
    Trophy Points:
    18
    Joined:
    May 9, 2012
    Location:
    Sydney
    Members Ride:
    Ve sv6
    As above a timing change doesn't need changing like a belt does however the 07 models and below had some timing chain issues with it stretching. Does your engine light come up ?
     
  4. Mrezk

    Mrezk New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Apr 26, 2014
    Location:
    Victoria
    Members Ride:
    Omega VE 2007
    My VE Omega 2007 stop engine by itself on low speed when raining or wet causing stop wheel stirrings , breaks and need to restart engine again
     
  5. commodore665

    commodore665 expat Saffa

    Messages:
    2,736
    Likes Received:
    1,288
    Trophy Points:
    113
    Joined:
    Dec 30, 2011
    Location:
    New Zealand via Cape Town
    Members Ride:
    2005 SV6 & Alfa Romeo 156 V6
    If your engine is stopping at low speeds , when it's raining or wet , i would say it's a electrical fault .
     
    Jack Kolar likes this.

Share This Page