Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Holden VZ 3.6 Wagon exhaust problems

Discussion in 'XFORCE' started by jade helmbright, Oct 4, 2017.

  1. jade helmbright

    jade helmbright New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Oct 4, 2017
    Location:
    nz
    Members Ride:
    2006 HOLDEN COMMODORE vz 3.6 wagon
    !! please help !!
    I have recently purchased a 2006 VZ 3.6 wagon. I took it down to an exhaust shop because it was making a raspy sound. They assured me they could fix the problem but they made it worse. They cut the 2 rear mufflers off and replaced with straight pipe and replaced the end muffler with a coby/hotdog. Then told me the previous owner had removed both catalytic converters now they say the only way to get rid of raspy sound is to replace catalytic converters or run 2.5 straight pipe from where catalytic start to rear muffler.

    located in nz so its legal to have no catalytic converters

    What would be the cheapest option to fix?
     
  2. Motorculture

    Motorculture Member

    Messages:
    724
    Likes Received:
    3
    Trophy Points:
    18
    Joined:
    Oct 20, 2011
    Location:
    Sydney, Australia
    Members Ride:
    VY SS Commodore
    Hi jade helmbright,

    Please visit one of our XForce Exhaust dealers near you and have them check out the problem. We are sure that they can help you out.

    You can find them here: http://www.xforce.com.au/where-to-buy

    Kind Regards,
    The XForce Team
     

Share This Page