Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Horn Problem

calais_cruzin

Calais_Rattling....
Joined
May 23, 2006
Messages
1,297
Reaction score
10
Points
0
Location
Gold Coast
Members Ride
92 VP Calais 3.8
Hey All

Got a dodgy horn, cleaned contacts under horn pad, brass ring and pin on back of wheel, still nothing

Sometimes its been working when trying to get it fixed.

Removed terminals at the horn, cleaned n put contact grease on, hooked up with horn pressed n it fired up, then stopped when i tried again.

Put a brass washer over the pin, no go, put contact grease still no go. the contact ring is clean as besides the slight amount of contact grease that is now on there.

Relay clicks but no horn

Did work when i pressed the spring loaded pin in, but now its not.

Driving me crazy, just want horn to toot at retarded drivers, soo many missed opportunities

Any other ideas that do not require removal of steering wheel?
 

Not_An_Abba_Fan

Exhaust Guru
Joined
Aug 18, 2006
Messages
14,196
Reaction score
712
Points
113
Location
Bunbury, WA
Members Ride
Strange Rover
Have you actually tried a different horn? Sometimes I have had them work intermittently.
 

FXST01

The Grey Man
Joined
Jun 3, 2005
Messages
1,108
Reaction score
47
Points
48
Location
Perth, WA
Members Ride
VP V6 Exec
Hook a testlight/globe up to where the horn is and see if it lights up. May still be a dodgy relay.
 

calais_cruzin

Calais_Rattling....
Joined
May 23, 2006
Messages
1,297
Reaction score
10
Points
0
Location
Gold Coast
Members Ride
92 VP Calais 3.8
hmm i recon its gotta be ground related at the horn pad/back contact

Gets a fluctuating voltage 9-11v at the horn, but should still work with that voltage.

Guess ill have to take steering wheel off see what i can come up with
 

Not_An_Abba_Fan

Exhaust Guru
Joined
Aug 18, 2006
Messages
14,196
Reaction score
712
Points
113
Location
Bunbury, WA
Members Ride
Strange Rover
Have you tried a different relay?
 

psi3800

New Member
Joined
Nov 21, 2011
Messages
45
Reaction score
0
Points
0
Location
South Australia
Members Ride
vn turbo
Have you checked to see that you havent worn down the spring loaded part on the steering column? I forget the actual name of it but they wear down and dont make contact with the back of the steering wheel after years of use. .
 
Top